Video thumbnails don't work in Gnome Files Fedora 38

New install of Fedora 38.

Installed for video thumbnails:

  • free rmpfusion -
  • ffmpeg, ffmpegthumbnailer
  • gstreamer1-plugins-ugly
  • totem-video-thumbnailer

I have deleted the contents of ~/.cache/thumbnails several times and restarted Files.

Despite this, only a few thumbnails out of many are displayed. I have been searching for solutions for 2 days and have still not solved the issue. I am surprised this is so complicated on such an advanced system as Fedora. Any help much appreciated.

Did you try gthumb:

sudo dnf install gthumb

Unfortunately still the same.

Do you have examples of extensions/video type you like to see?

So you are looking to a thumbnail of the content of the Video or you just would like to see which app is open it.

If you have examples we probably can check if it works with our setup.

No thumbnails for .mp4 videos. Thumbnails do work for webm, .flv, gif, mpeg, avi. However, there are also many .flv that do not have thumbnails.

Strangely, very few mp4 vids do have thumbnails. I checked the properties and the seem to be the same:

Are your videos on your computer or on a external storage in the network?

If External you might change the preferences>show thumbnails>all files in Gnome Files.

They are on my computer and I set show thumbnails to all. Still no love.

I do not have more ideas than the last link:

There is as section how you can debug/troubleshoot if needet.

1 Like

Thanks for that link. It was very detailed. I went through all the steps and have some clues but have not solved the issue yet. Below I will print the debug log of Nautilus when creating thumbnails for successful ones and unsuccessful ones. I am not able to figure out what the problem is. Maybe you can.

This one did NOT create a thumbnail:

(totem-video-thumbnailer:2): GLib-GIO-DEBUG: 18:36:26.015: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
(org.gnome.Nautilus:22776): GnomeDesktop-DEBUG: 21:36:26.133: About to launch script: bwrap --ro-bind /usr /usr --ro-bind-try /etc/ld.so.cache /etc/ld.so.cache --symlink /usr//bin /bin --symlink /usr//lib64 /lib64 --symlink /usr//lib /lib --symlink /usr//sbin /sbin --setenv GST_REGISTRY_1_0 /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0/gstreamer-1.0.registry --bind /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0 /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0 --ro-bind-try /etc/alternatives /etc/alternatives --proc /proc --dev /dev --chdir / --setenv GIO_USE_VFS local --unshare-all --die-with-parent --setenv G_MESSAGES_DEBUG all --bind /tmp/gnome-desktop-thumbnailer-G72P61 /tmp --ro-bind /home/me/Videos/smalldog.mp4 /tmp/gnome-desktop-file-to-thumbnail.mp4 --seccomp 14 /usr/bin/totem-video-thumbnailer -s 256 file:///tmp/gnome-desktop-file-to-thumbnail.mp4 /tmp/gnome-desktop-thumbnailer.png

This one DID create a thumbnail:

(totem-video-thumbnailer:2): GLib-GIO-DEBUG: 18:36:25.178: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
(org.gnome.Nautilus:22776): GnomeDesktop-DEBUG: 21:36:25.254: Failed to launch script:
(org.gnome.Nautilus:22776): GnomeDesktop-DEBUG: 21:36:25.255: About to launch script: bwrap --ro-bind /usr /usr --ro-bind-try /etc/ld.so.cache /etc/ld.so.cache --symlink /usr//bin /bin --symlink /usr//lib64 /lib64 --symlink /usr//lib /lib --symlink /usr//sbin /sbin --setenv GST_REGISTRY_1_0 /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0/gstreamer-1.0.registry --bind /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0 /home/me/.cache/gnome-desktop-thumbnailer/gstreamer-1.0 --ro-bind-try /etc/alternatives /etc/alternatives --proc /proc --dev /dev --chdir / --setenv GIO_USE_VFS local --unshare-all --die-with-parent --setenv G_MESSAGES_DEBUG all --bind /tmp/gnome-desktop-thumbnailer-E0XQ61 /tmp --ro-bind /home/me/Videos/demello.mkv /tmp/gnome-desktop-file-to-thumbnail.mkv --seccomp 14 /usr/bin/totem-video-thumbnailer -s 256 file:///tmp/gnome-desktop-file-to-thumbnail.mkv /tmp/gnome-desktop-thumbnailer.png

Then I tried to manually create a thumbnail in verbose mode. Below are one that worked and one that didn’t.

Did NOT work:

[me@fedora Videos]$ totem-video-thumbnailer --size 256 --verbose ~/Videos/chaka.mp4 chaka.png
TotemVideoThumbnailer-Message: 21:33:21.272: Initialised libraries, about to create video widget
TotemVideoThumbnailer-Message: 21:33:21.274: setting URI file:///home/me/Videos/chaka.mp4
TotemVideoThumbnailer-Message: 21:33:21.274: Video widget created
TotemVideoThumbnailer-Message: 21:33:21.275: About to open video file
TotemVideoThumbnailer-Message: 21:33:21.350: Checking whether file has cover
TotemVideoThumbnailer-Message: 21:33:21.350: totem-video-thumbnailer couldn’t find a video track in ‘/home/me/Videos/chaka.mp4’

DID work:

[me@fedora Videos]$ /usr/bin/totem-video-thumbnailer --verbose -s 256 ~/Videos/demello.mkv ~/Videos/chaka.png
TotemVideoThumbnailer-Message: 07:01:43.024: Initialised libraries, about to create video widget
TotemVideoThumbnailer-Message: 07:01:43.027: setting URI file:///home/me/Videos/demello.mkv
TotemVideoThumbnailer-Message: 07:01:43.027: Video widget created
TotemVideoThumbnailer-Message: 07:01:43.027: About to open video file
TotemVideoThumbnailer-Message: 07:01:43.103: Checking whether file has cover
TotemVideoThumbnailer-Message: 07:01:43.103: Opened video file: ‘/home/me/Videos/demello.mkv’
TotemVideoThumbnailer-Message: 07:01:43.103: About to seek to 0.333333
TotemVideoThumbnailer-Message: 07:01:43.104: About to get frame for iter 0
TotemVideoThumbnailer-Message: 07:01:43.107: Frame for iter 0 is interesting
TotemVideoThumbnailer-Message: 07:01:43.108: Saving captured screenshot to /home/me/Videos/chaka.png
totem-video-thumbnailer couldn’t write the thumbnail ‘/home/me/Videos/chaka.png’ for video ‘/home/me/Videos/demello.mkv’: Failed to open “/home/me/Videos/chaka.png” for writing: Permission denied

That it failed to save the thumbnail is not important to us here as it shouldn’t have permission to write here. What is important is it did create the thumbnail.

Maybe you can make some sense of this as I cannot. Thanks

Ok, I finally found the solution in case anyone else is struggling with the same problem. The problem is that Totem thumbnailer does not work correctly. The solution is:

  1. Shutdown nautilus.
  2. Remove totem.thumbnailer from /usr/share/thumbnailers
  3. Delete ~/.cache/thumbnails/ sudo rm -r ~/.cache/thumbnailers/
  4. Install ffmpegthumbnailer if you don’t have it already.
  5. Open nautilus and thumbs should generate correctly.

I don’t know why Fedora is including faulty software in their releases.

Because users as you ask for help and when they find an error they not report it :wink:

Where should I report it?

Just check if you find something before file a new bug. I had a quick look and could find nothing specific.

It was way too complicated with new sign-ins and so on. No wonder many don’t report stuff. I may look into it again when I have more time.

If everyone had that attitude no problems would get reported and nothing would change.

I encourage everyone to stretch just a little and make what effort they can to report noted problems with as much information as is possible. This helps the developers to identify needed fixes.

1 Like

Thanks for finding this solution. I was scratching my head as to how to remove totem from the thumbnailers folder until trying sudo rm -r totem-thumbnailer or something along those lines.

I’ve been dealing with this problem for years, and I’ve spent the last 3 days trying to resolve it after installing Fedora WS again on a new disk. This problem reoccurs every time I install Fedora, which so far happens every 6 months or so (for various, mostly unrelated reasons).

I’ve probably looked at about 50 or so posts about this issue on various platforms, and read deeply into some issues (including this one). The proposed solutions normally point to having the correct codecs installed but none of the steps solve the problem. After extensive research it looks like Totem simply doesn’t work properly, as @fdr97 says. I read that Totem is unable to play certain codecs (h.265 implied, among others) and was never designed to.

I’ve been having thumbnail issues for years. The main reason I’m even using Gnome is because KDE’s Dolphin is awful and that’s not mentioning thumbnails, which has its own set of fixes that are necessary to get thumbnails working. ffmpegthumbnailer appears to work for both Gnome and also KDE.

I’ve searched far and wide for different thumbnailers over the years, it doesn’t help that ffmpegthumbnailer comes in various flavors/names on different distributions and it’s hard to differentiate them. I wasn’t aware Totem was even the alternative name for Gnome’s default video player, I thought it was just a thumbnail generator.

Why is Totem faulty, and why hasn’t this been fixed?

If everyone had that attitude no problems would get reported and nothing would change.

And maybe that would explain why nothing changes. The problem is that everyone does have that attitude, of course they do, no one has time to go through the process. The kind of people that report are probably the same kind of people who have the technical means to solve the problem themselves, because they’re more motivated to solve these kinds of problems.

I tried to report a bug on Firefox and that took me a lot longer than I would like, I had to create an account on bugzilla, follow the very strict format, and in the end I gave up responding to follow up questions. And I’m someone who is deeply involved in tech, even I don’t have time for this crap.

Just posting this reply required me to create an account with fedoraproject.org, totally separate from discourse (the name of this forum software, which should be more obvious but that’s a discourse problem). Clicking on sign up takes me to fedoraproject.org, after creating the account I couldn’t log in due to “system error”. Discourse uses single sign-on (SSO) to acquire credentials from fedora, I had to make two accounts to register here. Slight digression.

This is why Linux will always be the masochists choice. In the issue I linked above, an “inexperienced” user, who has actually used Linux for years, does everything right. He’s described his problem in detail, and the community has graciously given their support. And yet he concludes that the solution is…to use Windows. If that’s not deeply telling, I don’t know what is.

And the same here. The solution is to stop using Totem and to use something else. All I can say about that is:

Not my preffered work flow, but certainly doable.

2 Likes

No
Those who report the issues are those who are irritated enough by the problem to actually ask for a solution instead of just voicing frustration. If you wish a fix instead of just accepting things as they currently are then you should dedicated the time to report issues and support the developers as they try to find a solution.

If those reporting the issues had the technical expertise you note they would contribute the fix.

I mean, yes, I completely agree with that assessment. I belong in that category. I only report bugs when I’m frustrated enough by them. But I am still more motivated than the average person who just puts up with it, and that probably reflects my above average technical expertise. Correlation is not causation, though.

But my point still stands, reporting bugs should be easier and more straightforward, and so long as it’s not, problems will go unreported, because the difficulty in reporting bugs is reflected in people’s attitudes toward reporting. Make reporting easy and accessible, and you’ll get more reports, and problems will hopefully get fixed.

2 Likes

The naming of project might indeed be a problem. And also the way how configuring and distribute, can be a challenge. But I guess the biggest challenge is the communication between developer/technicians and End-users. To make an approximation both sides have to be willing to understand the other one.

For the End-user it means, he has to be willing to get in to the complicated stuff of making an account and understand how to make a bug report, while the developer/technicians have to remember that they also have been once beginners and should avoid to make bad comments. Even if you are not a beginner you all ways have to be resilient and try it again believing you can make a software/hardware/documentation better.

Here a nice example I had the last days … and it is not the first time I reported an Issue with Lightdm. The old issue still exists and I had to move on. Sometimes it is the only thing you can do.