Installing flash for firefox

Hi guys,

Is this the proper way to get the flash plugin to work in Firefox on Fedora 30?


1 Like

Yes is does, see this TOPIC:

same here:



Great, thanks. I’ll accept your answer as the solution.

1 Like

Hi hhlp,

In my case for Fedora 31 this seems not to work. Is that normal? Is there something extra that needs to be installed?
Should I use a new discussion for this? (it’s my firs comment here on :slight_smile:

Kind regards,


sudo dnf install flash-player-ppapi 

I’ve installed and I can’t see flash on firefox…

Check via this Page, I realized I don’t have flash install it:

Check step 5. Verify whether Flash Player is installed or Enable just click on the Image, on this Page:

Google Chrome

If Chrome will start, type chrome://components in the address bar and look for Adobe Flash Player in the list.

Works but is disable by default:


Mozilla Firefox

If Firefox starts, type about:plugins in the address bar and look for Shockwave Flash in the list.

Compatibility Problem:

Mozilla removed the “always activate” option for Flash Player content on the Internet. While it is still possible to play Flash content using Firefox, it is no longer possible to configure Firefox to load Flash content automatically on specific sites going forward.

Firefox won’t support the “remember this decision” option anymore when it comes to Flash content.

Firefox will drop support for Flash at the end of 2020 just like Google Chrome,Microsoft Edge, and many other browsers.



Thanks a lot! I installed it and I can’t see Flash of Firefox as well :pensive:

Following your link ( in Chrome I can see the following:

On step 5 (following your link) I get an error message “failed to download” on the place where the plugin should be loaded.

Good to know that at the end of 2020 Flash will not be supported anymore, so hopefully less websites will use it :smile:

Kind regards,


Hello Fedora Community!

I’m having problems installing the Adobe Flash Plugin in Firefox.
I followed this instructions but it is still not working properly

Now, when I read the guide from the Firefox Team it says that it needs to be unpacked from the .tar.gz and then copied to the /usr/lib/mozilla/plugins directory. I have done it already but it is still not working.

Also there are many guides out there saying the plugin should go in ~/.mozilla/plugins directory.

What is the proper way of installing it? Does any of you have had success installing it?

Hi sportacus and welcome

You can ignore the instructions on the site. You don’t need them since Fedora (and RHEL, etc) have a repository provided by Adobe. All you need to do is install the repository itself and then install the flash plugin from that repository. Of course, you’ll get updates automatically from that repository too (well, for as long as Adobe keep updating flash). You can do that with these two commands:

sudo dnf install
sudo dnf install flash-plugin

I’ve never needed all the other stuff (flash-player-ppapi alsa-plugins-pulseaudio libcurl) so I recommend you just start with flash-plugin - you can always install the other stuff later if you need to.

Note the advice on the if-not-true-then-false site about Wayland.

1 Like

I’ve followed the instructions
[giuliohome@localhost ~]$ sudo dnf install flash-plugin alsa-plugins-pulseaudio libcurl
Last metadata expiration check: 0:14:40 ago on Fri 27 Mar 2020 06:19:47 PM CET.
Package flash-plugin- is already installed.
Package alsa-plugins-pulseaudio-1.2.2-1.fc31.x86_64 is already installed.
Package libcurl-7.66.0-1.fc31.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
but I still can’t see the flash player working in firefox…

Nevermind, I’ve found, firefox-x11 is required!
Found the suggestion here in this blog. (… ops… I’ve received the warning that @sportacus already posted the link above, but it does work in my case)
sudo dnf install firefox-x11
now launching
(notice: not just firefox)
the adobe flash test is passed ok
and then I can first activate and then play the flash players in the pages where they are needed.

Thanks @jonathans
The solution that you stated above worked flawlessly. I installed the repository and used only

sudo dnf install flash-plugin

This command installs the NPAPI version of Adobe Flash. Then I had to enable the Xorg by disabling Wayland stated in the if-not-true-then-false guide, because otherwise the plugin doesn’t work.

@giuliohome in my case, there was no necessity to install Firefox X-11

in my case, there was no necessity to install Firefox X-11

Sure, @sportacus, but since the tutorial reads:

If you can’t use firefox-x11, then you can disable Wayland

I preferred the former option.