Installed flash palyer in Firefox dosent work

Hello everyone, I am newcomer for Fedora, and I have some problems with flashplayer in Firefox.

I installed flash player by next commands in terminal:

  1. rpm -ivh
  2. rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
1 Like

Effectively, all this does is place a file within /etc/yum.repos.d/ called adobe-linux-x86_64.repo and then imports the GPG key which was used to sign the packages stored within the repo. This does not actually install the package.

You probably now want to run the following:

$ sudo dnf install flash-plugin

If you continue facing issues with the Flash player, let us know what you are trying to do and in what application you are trying to do it in.

1 Like

Thanks for your answer.

Use $ sudo dnf install flash-pluginand here is terminal output:
Last metadata expiration check: 1:21:36 ago on Thu 28 May 2020 01:12:04 PM MSK.
Package flash-plugin- is already installed.
Dependencies resolved.
Nothing to do.

I setup plugin in firefox, but it still dont work.
On page about:plugins flashplayer plugin exist, but many players still not working

moons ago when I was using flash I run a script after flash installation.
It main content was:

/sbin/restorecon -v ~/.mozilla/plugins/;

maybe this could help today too ?

Thank you for your advice, but it is not working.
After using this command nothing happen

Hello @lastvegas …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Could you please test this TOPIC


1 Like

Thanks for link for this guide, but I installed flashplayer plugin with this guide, so this is not so useful.
Thank you for your advice.

let’s start with the beggining you follow the step before, we know now, you have flash install it in your system:

  1. and What next?
  2. What do you want to accomplish or todo?
  3. What web pages are you in, or have you got trouble?
  4. What problem do you have?
  5. What applications?

Could you please explain more in Detail?, please be more specific…


1 Like

I have problem with videos on twitch, and other resources, except youtube, I checked plugins and didnl’t see flashplayer, searched some information about it, and find this guide ttps://
I installed flashplayer in firefox-X11 by this guide Adobe Flash Player 32 on Fedora 32/31, CentOS/RHEL 8.0/7.7 – If Not True Then False , and after that many videos don’t work, so thats all.
Sorry for my ineffective narration, really dont know what can i tell you about this more

1 Like

Tried it and it didnt working, thank you for advice

1 Like

I don’t have any problem with normal firefox and flash install on it and see twitch:

why you don’t revert:

4.2 Disable Wayland and Fallback Xorg

If you can’t use firefox-x11, then you can disable Wayland modifying /etc/gdm/custom.conf , uncomment WaylandEnable=false line:

# GDM configuration storage

# Uncomment the line below to force the login screen to use Xorg


And reboot:


and install al plug-ins:

sudo dnf install gstreamer1-plugins-{bad-\*,good-\*,base} gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel
sudo dnf install lame\* --exclude=lame-devel
sudo dnf group upgrade --with-optional Multimedia


I am very grateful to you for trying to help me, but this method did not work, and the situation with the flash player does not change, thank you very much for you advice

If video in Firefox does not worjk in some pages try to restart in add-ons Disabled Mode or Safe mode or Refresh FF. Find that in FF / Help / Troubleshooting information /