Firefox and Flash Plugin on Silverblue

Hello all,

After installing the flash plugin from Adobe onto Silverblue using the guide from https://docs.fedoraproject.org/en-US/quick-docs/using-adobe-flash/ , my Firefox still does not see any Flash plugins in the “Add-ons” page. I occasionally need the Flash plugin to access old server Web UIs at my workplace. My workaround has been using Chrome on a Windows work laptop because actually Flash does not work on FF for that Windows machine either.

Is this something FF has done? When poking around DDG and Google searches I don’t see anything about FF completely dropping support for flash but I cannot get it to work on either box. I refuse to put Chrome on my Fedora install, so if this is something that cannot be undone I will just use Chrome on my Windows machine for the occasion, but I would like to be able to do everything from my Silverblue install.

Thanks for any help you can provide! Regards,

Matt

Can anyone help? I still cannot use Flash on Firefox and now a class that I am in is using it. I really do not want to use the Windows laptop + Chrome to do my schoolwork.

@mpphill2 Use Chrome on Silverblue

Hi Matt,

  1. go to : Adobe Flash Player

  2. choose to download: Step 1: Linux 64-bit ; Step 2: FP32 Linux64 (tar.gz) NPAP

  3. unpack the downloaded tar.gz file, go into this unpacked folder and copy the “libflashplayer.so” file

  4. in Nautilus go to your home folder (Alt + Home) , press Ctrl + H, find the ./mozilla/plugins folder

  5. put the copied file libflashplayer.so into the folder ./mozilla/plugins

  6. restart Firefox

Jan

Thanks for the help jankocan, but that still did not work. I even tried symbolically linking the /usr/lib64/flash-plugin/libflashplayer.so file to the .mozilla/plugins directory.

However I did find something that worked… I noticed when I ran “firefox --help” the very first thing that came up was “Usage: /usr/lib64/firefox/firefox”, so I tried running that command. Then BAM, I had Adobe Flash in my add-ons. I really don’t understand the difference, but I’m happy it is working now.

Hi mpphill2,
I am running the same issue and not successfully yet

As I am more newbie, could you explain me step by step what have you done ?

Gabriel

You may also try using gnome xorg instead of wayland(default one)

Well first you are going to want to install the Adobe repository:

sudo rpm-ostree install http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm

Then you install the plugin:

sudo rpm-ostree install flash-plugin

Next you first want to go to your Firefox and check that Flash isn’t already working in your Add-ons. If it’s not there then exit that instance of Firefox, go to Terminal, and run the command:

/usr/lib64/firefox/firefox

Check Add-ons again and it should be there.

https://docs.fedoraproject.org/en-US/quick-docs/using-adobe-flash/

Hey,
thanks for step by step approach

So I did what you suggested and I have a suspicious “error”.
When check firefox adobe plugin is still missing.
Only difference when I open firefox with comand /usr/lib64/firefox/firefox is that in plugins appears shockwave flash, but it does not work properly.

E.g. it works on udemy after allowing running flash, but not on the other pages. If I start firefox normally there is no shockwave and even udemy does not work.

This is the error I get in terminal. Removing and reinstall did not help
[~] sudo rpm-ostree install http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm Downloading 'http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm'... done! error: Package 'adobe-release-x86_64-1.0-1.noarch' is already layered [~] sudo rpm-ostree install flash-plugin
error: Package/capability ‘flash-plugin’ is already requested