Google Crome flash don't work

My OS = Fedora 30 LXQT (updated today)
I’ve installed google-chrome-stable from Fedora’s repo.

$ rpm -q google-chrome-stable

Adobe Flash Player Help says

Flash Player is pre-installed in Google Chrome and updates automatically!

Your Flash Version = 24.0.0
Your browser name = Google Chrome
Your Operating System (OS) = Linux

but flash at the bottom of page says “download failed”

Other flash-based sites don’t work, although flash is allowed.
For example Hoop Game

What is wrong?

Hello @sparcher! Welcome to the community. Please take a minute to go over the posts in the #start-here category if you haven’t had a chance yet.

Just to be accurate for the record, Google Chrome is not in the Fedora repository, but you enabled a third party repository, maintained by Google itself.
Read more on what you can find in the Fedora official repository: What can be packaged :: Fedora Docs

1 Like

Sorry for inaccuracy.
To be accurate, next commands used

dnf install fedora-workstation-repositories
dnf config-manager --set-enabled google-chrome
dnf install google-chrome-stable

“fedora-workstation-repositories” confused me

No problem. :+1: In this forum we are here to also learn new things, not only to report problems. :slight_smile:

dnf info fedora-workstation-repositories
Description  : Repository files that make some select non-Fedora software available
             : via search in gnome-software.

Talking about Chrome.
Did you check if Flash is updated?
Write chrome://components in the URL bar and click on Check for updates. Eventually reload this page.

Moreover, go to the Flash setting chrome://settings/content/flash and try to enable Ask first. Then reload the page with the Flash content.

Check this Google help page: Flash Player is no longer available - Google Chrome Help


You can try chromium-freeworld and chromium-pepper-flash from UnitedRPMs.

I’d always strongly advise using RPMFusion as the only repository other than Fedora’s standard ones. It has Chromium in it too.

1 Like

@FranciscoD, I’m aware of that, but RPM Fusion has no chromium-pepper-flash which is the cause of this thread.

1 Like

@sparcher, I’ve checked on my system (Gnome DE, google chrome the same version you have).

Adobe’s page in my case says:

Your Flash Version	-- 32.0.0
Your browser name -- Google Chrome

Note my version is 32, while yours reported is 24.

Please follow @alciregi’s suggestions to try to update chrome’s built-in plugin.

In my case, even after trying to update chrome’s plugin and enabling flash I’ve got the following result:

Adobe’s test page – after reloading it I see Google Chrome’s popup saying “Adobe Flash plugin is blocked because it’s outdated” with two buttons: [Update plugin] and [Run once]. Update plugin takes me to the Flash Player is no longer available - Google Chrome Help

However if I click run once – flash content loads successfully.

On Hoop Game page worked the same but only after I’ve disabled all the plugins which blocked advertisement (note a blue column on your screenshot) – Ublock origin included. After it showed me adverts for some time outdated plugin popup appeared and only after that flash content was loaded.

Here’s some random flash games site which worked without additional hoops Hoop Game required (no pun intended) – but still only after I clicked [Run once] button.

1 Like

Hrm, not really. The OP is mainly speaking about Chrome, not Chromium. Chrome from google includes all of this (or so I thought).

1 Like

I read Google help page before.
In my screenshot you can see Flash alowed.

've read ones more…
chrome://components show Version

after press “Check for updates” - Version :frowning:

Thanx. I didn’t know about UnitedRPMs. Will install and explore.

I’ve installed Cromium from RPMFusion yesterday’s evening.
Thуn add pepperflash as Installing Chromium or Google Chrome browsers :: Fedora Docs says.
Everything work fine.
Flash works.
YouTube works. Even without chromium-libs-media-freeworld.

Chrome :frowning:


Maybe I don’t understand something and need to install some packages, for example flash-player-ppapi- ?

Can you show me exhaust commands

rpm -qa | grep -i flash


find /usr/lib64 -name "*flash*so"

Google Chrome has flash built-in, you’re right.

I’m quite sure Chromium does not – I assume that’s why it needs chromium-pepper-flash @vgaetera suggested. Though I have to say, I haven’t used Chromium for a very long time.


No, you normally don’t. Google Chrome has flash plugin built-in – and either updated automatically, or at least updated whith google-chrome-stable package – at least so I though.

That’s strange, mine shows version

rpm -qa | grep -i flash output is empty – and I know for sure I have no flash packages installed on my system.

$ find /usr/lib64 -name "*flash*so"

And after some poking around I’ve found that Google Chrome’s flash library is located at:


So it’s actually isn’t included in the google-chrome-stable rpm package, chrome seems to be downloading it after installation. That’s news for me – but then I don’t use flash, almost ever.

Just so you know – youtube (and other major video tubes / streams) doesn’t need flash to work for several years already. They all moved to html5 for video playback in the browser.

As far as I understand, at this time you’ll need flash for some legacy stuff (where maintainers can’t or simply not interested to move), flash games being the most probable / widespread usecase.


exist. But it’s empty.

I create subdir and put manifest.json there.

chrome://components/ says Version: says 24.0.0

Flash dont work.

Three machines. Two phisical, one virtual.
All the same.

I surrender.

1 Like

@sparcher, isn’t your Ublock Origin configured to block flash by any chance? Have you tried disabling it, at least for troubleshooting?

Well, I’ve tested it for you on my work pc and home pc, and it’s working for me on both. Though I’ve never really bothered with flash, I usually have no use for it.

I’m quite sure that’s not how it’s supposed to happen, i.e. you shouldn’t put it there manually. It looks like something in your configuration prevents google chrome from updating flash plugin – or even downloading it in the first place. Firewall rules?

1 Like

I tried everything.

  1. deactivate ublok origin;

  2. systemctl stop firewalld.service;

  3. clean install Crome (without any add-ons)

  4. even try another ISP

nothing helps :frowning:

Maybe you know IP from wich flash must update?
tracerout, wireshark maybe help…

Can you try default Fedora Workstation (Gnome one) installation in a VM? It’s weird, but can it be LXQT lacks something google chrome needs to update it’s flash?

I’m not that good with Wireshark, but I can try to trace the packets google chrome uses to update flash – if you’re interested. It’ll take some time though… Please tell, do you want me to or not.

For me your story is one more nail in the flash’s coffer. It’s known to be buggy and cause many instabilities/insecurities – especially on Linux )) We really should get rid of it, it’s a bad tech.