Browser video decoding issues (was "Hardware accelerated Chromium?")

In Slack huddles, everyone can see my camera feed but everyone else’s video looks like this to me

“Your client does not support hardware acceleration”

I’ve checked that “Use hardware acceleration when available” is checked in chromium settings and I’ve also tried with that unchecked. Anyone know how to fix this?
I’ve also noticed a lot of videos around the web are not playable and I’m assuming that is related to this issue.

i don’t know if that will help or not but, have you tried forcing mesa version ? look in the thread about running obs, you’ll see how to prefix chromium command with environment variables.


if it help obs and other softwares, maybe it will help with your chromium and webcam issues ?

1 Like

That is one thing that I tried and unfortunately it seemed to have no effect. Slack is able to give me a background on my video feed, which I thought was a hardware accelerated feature but maybe not :man_shrugging:

that ‘slack’ thing, maybe it has a requirement list on its homepage?
that way you’d know for sure what it needs. i think asahi will release its fedora spin soon, there might be some improvement on the gfx driver too alongside the rest. or maybe trying to force software rendering (replicating 3d acceleration but in software instead of hardware) or maybe trying to make your own build of that ‘slack’ (forcing lower opengl version while doing so) ? i’m just giving some ideas and suggestions here.

I am already using Fedora Asahi Remix. I can’t find a list of requirements but I did find this in chrome://gpu

I’m betting one of those disabled things is the problem. Btw, Slack is just a website ( that I’m loading through Chromium, so I can’t make my own build of it

current asahi’s fedora spin is still a preview iirc, official release is yet to come, unless i’m mistaken. about the rest of what you reported, i have no more ideas unfortunately. maybe someone will come up with something else? otherwise your best bet might be to wait for the release and hope it will have updated gfx driver (i think it will, but that’s just my own opinion, i don’t know if that will be the case or not for sure).

Your hardware acceleration is fine. More likely, Slack is buggy or their message misleading (or they somehow depend on bleeding edge stuff like WebGPU, but that’s unlikely).

I’ve also noticed a lot of videos around the web are not playable and I’m assuming that is related to this issue.

When did you install? Recent installs should have H.264 out of the box. For older installs, you need to dnf install openh264 mozilla-openh264 gstreamer1-plugin-openh264. If you don’t have those installed, that’s your issue. H.264 decoding would be required for videoconferencing to work properly.

Also give Firefox a shot, it’s the default browser for a reason :slight_smile:

Thanks for the suggestions! I installed mid-August I think, I was missing the mozilla-openh264 package. Hopefully that will help, I’ll let you know when I try again tomorrow. I did try Firefox, but for some reason Slack doesn’t give me the button to start/join a huddle. It’s weird because according to the docs huddles should work in Chrome and Firefox.

Unfortunately installing mozilla-openh264 did not fix it. I can’t even play instagram videos in chrome. It’s not just me is it? It’s weird because I thought I had incoming slack videos working in chrome at one point with Asahi

Instagram videos do work in Firefox so that’s good

I was able to get instagram videos to play in vivaldi by following this guide (couldn’t get the same trick to work for chromium). I’ll try Slack huddles in Vivaldi tomorrow and see how that goes

I am able to see incoming video in Slack huddles in Vivaldi after applying the trick above. Adding a background on my video doesn’t work unfortunately :laughing:
Of all the trade-offs in the various browsers, this is the most acceptable for me so Vivaldi is now my default