Web Browser hardware video decode issue

I am a newbie to fedora and linux. I have installed linux just last month. Can someone help me with browsers.

Any chromium based browser doesn’t provide hardware accelerated video decoding. It shows many errors. I have non free repos enabled and rpm fusion repos enabled too. I have install intel media driver and libva utils and using vainfo, everything is enabled. But whenever I try to use my web browser for watching videos, it takes my cpu usage to 160% and that causes my laptop to have terrible battery backup.

Using the flags --use-gl=desktop or --use-gl=egl doesn’t work either. They show like a hundred error and even disable the gpu altogether. The ozone is set to wayland. I am using kde fedora edition.

Can anyone help me fix this??

My specs:

Intel pentium silver n6000
Intel jasperlake 32EU iGPU
Azurewave Qualcomm qca9377 wifi and bt card
8gb ram ddr4
256gb nvme

1 Like
  1. Check Driver Installation: Make sure your Intel GPU drivers are correctly installed and up to date. Since you’re using an Intel Pentium Silver N6000 with Intel Jasperlake graphics, you should ensure that the appropriate drivers are installed. You can check this using the lsmod command to see if the i915 module is loaded.
  2. Verify VA-API Setup: Since you’ve installed the Intel media driver and libva utils, let’s ensure that VA-API (Video Acceleration API) is correctly set up. You can use the vainfo command to check if VA-API is detecting your hardware and codecs properly.
  3. Browser Configuration: Try configuring your Chromium-based browser (e.g., Google Chrome, Chromium) to enable hardware acceleration explicitly. Sometimes, the default settings might not utilize hardware acceleration effectively. You can do this by going to the browser settings and enabling hardware acceleration if it’s available.
  4. Check GPU Flags: Experiment with different GPU flags in Chromium. While --use-gl=desktop and --use-gl=egl didn’t work for you, you might want to try other flags or combinations of flags. Additionally, ensure that you’re using the appropriate flags for Wayland, as you mentioned you’re using KDE Fedora Edition with the Ozone set to Wayland.

Best Regard
Danish Hafeez | QA Assistant

1 Like

Secureblues Chromium flags

Does enabling --ozone-platform=wayland help? You could add it like in this repo, or to the desktop entry and possibly more ways.