Having trouble accessing certian websites. Multiple browsers. Java/codec issues?

Hi i recently have been trying to take advantage of a 2 month trial i have with datacamp.com. The FAQ there says that linux usually doesn’t come with all of the proper codecs available due ot it’s stance on FOSS. I’ve tried downloading Java & Flash codecs in a hope that it will load but the website is in a constant loading loop.

I’m using a Lenovo ThinkPad Edge E530C with 8gb ram and an intel i3 core. Everything else is running fine just this website.

Ah, perhaps try Chrome first since it includes the necessary proprietary bits. Unfortunately, if they insist on using non-FOSS components, there’s little that can be done :frowning:

Tried with Chrome and the same thing happened. I did download the User Agent switcher Extension and using “Internet Explorer 11 on Windows” is the only one i can get to work. Why is that? Just curious now that i found a workaround.

It doesn’t seem to me that such site uses Java or Flash.
Flash is near end of life. Even Java is very rare nowadays on the majority of the web sites.
Btw videos are working for me as well as the exercises (I’ve not tested the site extensively), and I’m using Firefox.

I would advice you to install RPMFusion repository if you haven’t already done that.
Then install some codecs.

If switching user-agents makes it work, then the issue isn’t a technical one on your system. The website providers are filtering connections based on user-agents to allow Windows based browsers. So, the solution here is to ask them to stop filtering out non IE browsers.