Fedora Live Media hangs after GRUB

As the title mentions, Fedora Live Media for F38 Sericia goes to a black screen with only a “_” after selecting any option. I am using the Fedora Media Writer app on OpenSuseTW and have checked the checksum. I have tried:

  • Install
  • Check media and Install
  • Troubleshooting, basic graphics mode
  • Creating the install media with balena etcher, unetbootin, rufus (Windows)
    All of which yield the same result. I am aware that with my laptop, Surface Laptop 4 (Intel), I need to install the linux-surface kernel afterwards for full features but that shouldn’t have anything to do with this problem.
    I do remember previously having to change from SATA to AHCI on other laptops but OpenSuse TW installed just fine without doing so.
    I am at a loss for what to do as all the issues I find after searching around have to do with Nvidia drivers or other unrelated things.

In grub, edit the command line and remove “rhgb quiet”, to see debug boot messages. It might show some interesting error.

All I’m getting is:

Booting a command list


then nothing. The keyboard also does not respond.

EDIT: on Sericea only “quiet” exists, but on the Sway spin both “rhgb quiet” exist, and similar results in terms of output for both.

I recommend to test Workstation (or XFCE, if you need something lighter), just to compare whether this is not some Sericea problem.

You can try

sudo checkisomd5 -v /dev/sdX

where sdX is your flash drive device (see lsblk output) to check whether the image is correctly written. If not, it might be a faulty flash drive, or the tool created it incorrectly (use Fedora Media Writer, other tools are often broken).

If you can boot Fedora 36 installer but not 37 or 38, it might be this problem:

And since I see you have an Nvidia card, it’s always useful to try to disable the Nvidia card in BIOS, if possible.

This has been known to happen when having an nvidia gpu (or other newer gpus as well) when booting with the workstation media.
The fix seems to mostly be select the troubleshooting option for booting then select to boot with the basic graphics option.

1 Like

I have the similar issue one my surface pro 8 [Bug] Can't boot on Microsoft Surface devices

what is your device?