Install media don't boot in UEFI mode on certain motherboards

Problem

Fedora 37, 38 and 39 install media don’t boot on certain motherboards. You might see an error similar to the following (or none at all):

Invalid image 
Failed to read header: Unsupported 
Failed to load image: Unsupported 
start_image() returned Unsupported

Cause

A problem was identified and fixed in shim, an initial UEFI bootloader. Unfortunately, due to a difficult certification process for this component, the fix isn’t present on specified install media.

Related Issues

Bugzilla report: https://bugzilla.redhat.com/show_bug.cgi?id=2113005

Workarounds

If you’re affected, several workarounds exist:

  • Option A) Install Fedora 36 and upgrade.
  • Option B) Switch your motherboard to BIOS mode instead of UEFI and install an affected Fedora release this way.
  • Option C) If you really insist on booting an affected Fedora release install media in UEFI mode and you’re a power user, then you can do the following:
    1. Burn the affected Fedora release Live media to a USB flash drive.
    2. Mount the second partition from the flash drive, which is the ESP (10 MB size, FAT filesystem).
    3. Remove EFI/BOOT/BOOTX64.EFI from that partition. Also remove EFI/BOOT/BOOTIA32.EFI and EFI/BOOT/grubia32.efi, in order to make more space available (these files shouldn’t be needed).
    4. Download shim-x64-15.4-5.x86_64, extract it, and find boot/efi/EFI/BOOT/BOOTX64.EFI in it.
    5. Copy the BOOTX64.EFI from the extracted RPM into the original location EFI/BOOT/ on the mounted ESP.
    6. The flash drive should now boot in UEFI mode on your system. Skip the media verification process during boot, it’s expected to fail (you’ve modified the install image).

You can discuss this topic here.

12 Likes