Install Fedora Silverblue 38 stalling?

Hello. I successfully installed Fedora SilverBlue 37 on a device a month ago. Today, I want to fresh-install Fedora 38 on the same device, with a new SSD. Old SSD was 32GB SSD, new is 2TB Crucial SSD. Trying it with the new SSD, I get to see the menu selection for test media and install, or just install. I tried both. Either way I get about 10 lines of text and then the HDMI is disconnected, and the PC appears to go in to a frozen state. I have to long-press the power button to turn it off. I did leave it 2 hours the first time in case it came back. I am unsure what I can do to determine the issue here. I don’t believe there is any logs, or anything that I can look at?

OK, I have more information. I chose the Troubleshooting > Install in basic graphics mode, and I got to see the error.

[8.305568] dracut-initqueue[1315]: Unknown deveice "/dev//run/install/repo//images/install.img: No such device
[8.309379] dracut-initqueue[1316]: Unknown deveice “/sys/”: No such device
[8.359584] dracut: FATAL: Failed to find a root filesystem in /run/install/repo//images/install.img.perblock on /dev/loop0, missing codepage or helper program, or other error.
[8.359591] dracut: Refusing to continue
[8.352733] dracut-initqueue[1331]: demsg(1) may have more information after failed mount system call.

I am guessing that something went wrong with the creation of the install media (USB drive), so I will try creating that again.

Did you use the Media Writer?

1 Like

Yes, I uused the Fedora Media Writer, downloaded from the same download page where the Fedora Silverblue 38 ISO was.

I even booted into my old Fedora 37 SSD, downloaded the ISO again, and downloaded the Fedora Media creator again, and then wrote the ISO to three different USB sticks, 4GB, 8GB, and 32 GB. None of them work, all the same message.

Is it just a bad ISO or image creator on the site right now? Is there a better media creator that I should instead be using? I can see that I previously downloaded “Imager_1.7.4.exe” Is that a better tool to create the install media?

Thank you

1 Like

Crazy. Maybe download the new ISO when it comes out, or just use a Fedora 37 ISO and try to install that and then manually rebase. Its weird but could work

Did you use the correct CPU architecture?

Try the torrent link

1 Like

You’re having issues with your thumb drive installer if I understood correctly.
Firstly a usb 3.0 thumb drive install wouldn’t take 2 hours to install. On newer hardware around 5-10 minutes. On older hardware about 20 minutes.

The 2 hours waiting for the installer to complete is unheard of.

A few questions:

  • are you using a new thumb drive? Is it usb 3.0 or more recent? If you flashed to a usb 1.0/2.0 drive, you’re install experience will be terrible.
  • did you plug the usb 3.0 drive into a usb 3.0 port? If you installed the drive into an older usb 1.0 port, then it’s possible this slow behaviour could happen, but you shouldn’t be using such old hardware to begin with. Look for the blue usb 3.0 ports and plug it in there.
  • did you ensure the thumb drive wasn’t mounted anywhere before flashing the image to the thumb drive? i.e. lsblk and check to see if the thumb drive has been mounted. If it has, unmount that thumb drive’s partitions. unmount /dev/sdb1 /dev/sdb2 /dev/sdb3
  • did you wipe the thumb drive before flashing the image to the thumb drive? This is important if the drive has been used for anything else or for earlier images. i.e. wipefs --all /dev/sdb
  • instead of using fedora media writer, you can use dd, the workhorse tool to flash the image: dd if=./Fedora-Silverblue-ostree-x86_64-38-1.6.iso of=/dev/sdb bs=4M status=progress conv=fdatasync

Thanks for the reply David. Yes, did eventually see the actual message and posted it in my reply to my post. I have tried 4 different USB thumb drives, and have created the thumb drive media from Windows and Linux, using the Fedora Media creator for both Windows and Linux, and I even downloaded the ISO itself twice, once from Windows and once from Linux. Still unsure what is happening.

Have you tried writing the netboot version instead of the workstation version? Im looking for a link to the iso now.

EDIT: Found it. It is under the server section on the new site. Download Page
Make sure when you boot you change the “Software Selection” to Workstation or whatever else you want or else it will install the server version.

1 Like

It worked today. I ran the Fedora Media creator from Fedora 37 this morning, and chose to download the Fedora Silverblue 38 iso from that tool, and the iso is now 3.2GB, where yesterday’s was 3.1GB. And the created USB stick works fine. I downloaded the ISO yesterday twice, once on Fedora, and once on Windows, so I guess the issue was found and fixed in the last 10 hours.

Thank you for your help.