F37 Silverblue unbootable, dracut can't see drives after any update since Feb 21

I’ve been running Silverblue since v33 or 34 and never had any trouble with it until now. The last successful update I ran was on Feb 21 and now any update applied after that time will not boot.

The system resets and starts the boot sequence and hangs for a minute or so. Then a flurry of dracut errors fill the screen and I’m left at the dracut emergency shell prompt. It says it couldn’t find the boot device and suggests perhaps rebuilding the initramfs.

While in the shell, I can see no drives. There are no “sdaX” or “disk” entries present in the /dev directory. It will recognize if I plug a USB drive in, but I can’t see my internal hard drive at all.

I tried enabling initramfs rebuilds with ‘rpm-ostree initramfs --enable’ and then updating. Again, it will run with the Feb 21 version with the initramfs rebuilt, but if I update to a more recent version I end up in the same place…dracut prompt with no hard drives available.

I also tried rebasing to the F38 but that gave the same result and I had to rollback again.

I don’t know if anyone has seen this before, but I’d really appreciate some help troubleshooting it. I’m kind of lost and not even sure where I should be looking to find the missing link.