Fedora 37 Workstations Can't Boot 6.2.7


I have two machines that can’t boot any kernel newer than 6.1.14. I’ve tried to research the problem, but the only similar bug reports I’ve been able to find seem irrelevant since I’m not using nvidia or realtek hardware (as most people reporting similar issues are).

Machine 1: ASRock X370 Gaming K4, Ryzen 7 1700, AMD Radeon RX 480. Disk encryption with luks. UEFI mode.

Machine 2: Gigabyte AX370 Gaming K7, Ryzen 5 1400, AMD Radeon RX 560. No disk encryption. BIOS mode.

I’ve been running Fedora on both machines for years, however both have had a fresh F37 install within the past 4 months. Both work flawlessly on kernel 6.1.14, but neither one can boot 6.2.7.

Machine 1: Freezes on the ASRock splash screen. Never shows luks passphrase screen. No disk activity, LED keyboard not illuminated/doesn’t accept CTRL-ALT-DEL. Requires a hard reset to access grub menu. Note that this machine also has 6.1.18 installed, and it can’t boot that kernel either.

Machine 2: After Gigabyte splash screen, kernel panic ending with the message “---[end Kernel panic - not syncing: timer doesn't work through Interrupt-remapped IO-APIC ]---”. Able to reboot with CTRL-ALT-DEL to access grub menu.

Incidentally, I have a third machine on F37 Workstation (an Intel-based Dell laptop) that boots just fine on kernel 6.2.7.

Can anyone point me to a relevant bug report, or do I need to file a new one? Besides versionlock-ing the one working kernel, what are my options here? I tried to build a vanilla 6.2.8 kernel based on the 6.1.14 config, but ran into an unhelpful error message and wanted to stay focused on trying to address the main problem.


EDIT: I see someone has posted a similar error message related to Silverblue. I’m using standard F37 Workstation, but their kernel panic looks like the one I’m seeing on Machine 2. This is different than what I see on Machine 1, but maybe the same cause?

From the grub menu, if you remove rhgb quiet before booting, do you get any more useful information that you can share with us

I have similar hardware on my laptop (Ryzen 4800H + RX5600), so I’m going to try to replicate this now by updating to the latest kernel, myself.

6.2.7 is booting fine for me here on similar hardware. Machine 1 sounds like you might have an unfortunately timed bigger hardware problem. :grimacing:

inxi output
$ inxi -CMSG
  Host: tirian Kernel: 6.2.7-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 43.3 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: Micro-Star product: Alpha 15 A4DEK v: REV:1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MS-16UK v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E16UKAMS.101 date: 07/28/2020
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 3021 min/max: 1400/2900 cores: 1: 2304 2: 3477 3: 2956
    4: 2523 5: 2900 6: 1733 7: 4167 8: 2900 9: 2105 10: 2514 11: 2308 12: 3312
    13: 3454 14: 3355 15: 4170 16: 4167
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel
  Device-2: AMD Renoir driver: amdgpu v: kernel
  Device-3: Chicony HD Webcam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~144Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.2.7-200.fc37.x86_64)

Hey, thanks for the replies. I had this in an early draft of the post, but must have removed it. . . On Machine 1, when I remove rhgb quiet and press F10 to boot, the screen freezes on the message “Booting a command list”. Can you elaborate on why you think Machine 1 might have a hardware problem? It still boots 6.1.14 without any issues–it’s only 6.1.18 and 6.2.7 that fail.

Machine 1 inxi output
  Host: {redacted} Kernel: 6.1.14-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 43.3 Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: ASRock model: X370 Gaming K4
    serial: <superuser required> UEFI: American Megatrends v: P4.50
    date: 01/09/2018
  Info: 8-core model: AMD Ryzen 7 1700 bits: 64 type: MCP cache: L2: 4 MiB
  Speed (MHz): avg: 3676 min/max: 1550/3700 cores: 1: 3678 2: 3669 3: 3693
    4: 3662 5: 3667 6: 3692 7: 3669 8: 3683
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: AMD Radeon RX 480 Graphics
    (polaris10 LLVM 15.0.7 DRM 3.49 6.1.14-200.fc37.x86_64)

When removing rhgb quiet on Machine 2, I see the same “Booting a command list” message, followed very briefly by Probing EDD (edd=off to disable)... ok, then immediately the kernel panic happens.

Machine 2 inxi output
  Host: {redacted} Kernel: 6.1.14-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 43.3 Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop System: Gigabyte product: AX370-Gaming K7 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming K7 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: F24e date: 12/06/2018
  Info: quad core model: AMD Ryzen 5 1400 bits: 64 type: MT MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 2893 min/max: 1550/3700 cores: 1: 3700 2: 3698 3: 3700
    4: 1550 5: 3700 6: 1550 7: 3700 8: 1550
  Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X] driver: amdgpu
    v: kernel
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: AMD Radeon RX 560 Series
    (polaris11 LLVM 15.0.7 DRM 3.49 6.1.14-200.fc37.x86_64)

Oh, I thought that was a typo. You’re running the older 560, not the 5600. So it’s possible there could be some regression related to your Polaris GPUs?

Hello All, I can report the same failing to boot issue on our AMD-based reverse proxy. As @hyph3n reported, we are seeing “Kernel panic - not syncing: timer doesn’t work through Interrupt-rempped IO-APIC” when using Fedora Kernel 6.2.7-100.fc36.

Machine Details.

  • Gigabyte A320M-S2H (fully patched bios)
  • Fedora Kernel 6.2.7-100.fc36
  • Fedora 36 Server
  • 1st Gen Ryzen 1200 Processor
  • RX550 Radeon gpu
  • Last known working kernel 6.1.15

Nice - it looks like we can probably narrow this down to 1st gen Ryzen platforms. Could one of you please file an issue for this on https://bugzilla.redhat.com with this information?

Also, it would be helpful if y’all could help us test future kernels as well, if you’re able, so we can prevent regressions like this from happening in the future:


There was already a bug report open, not necessarily explicitly tied to 1st Gen Ryzen CPUs though. Do I still create a new one? OP’s attachment image matches my situation.

Bug Report: 2181337 – Kernel Panic 6.2.7

1 Like

I believe GPUs mattering can be ruled out, as this is affecting me too, and I have a GTX 1060. Machine details:

  • Motherboard: Gigabyte A320M-HD2 (BIOS revision F51, happened as well with F31 and F23d)
  • CPU: Ryzen 5 1500X
  • GPU: GTX 1060
  • Fedora version: 37

The kernel panic happens on kernel 6.1.18 too, by the way.

1 Like

Not if it’s the same issue. You can add yourself to the watchers list.

Not to get too off topic here, but as a long-time Fedora desktop user (since version 10, circa 2008) I’m certainly experienced and technically inclined enough to help test the kernel. However, I’ve always found the barrier to involvement with this community quite high and frankly a bit intimidating.

For example, in the link you provided, it says right near the top that I can download a live test day image so I don’t have to make changes to my system. Great, that’s absolutely what I’d want to do, but in reading through the rest of that page, there’s no clear information on where to get it; I just see information on other ways to do the testing, ie. via VM or koji. I honestly don’t even know what koji is, and I don’t see any information on that page that tells me.

Then there’s a section that talks about preparing for testing and earning a badge. Do I have to take these steps if I’m running the bootable image, or is this only for koji users? Do I get badges if I’m testing with the bootable image? Do I need to run these commands on the image to do so? For that matter, what’s a badge for and why would I want one?

So eventually I click on the link to Fedora Magazine near the top of the docs page you linked. I notice an article there from March 4th called “Contribute at the Fedora Kernel, GNOME, i18n, and DNF test days”. Ok, sounds like what I’m looking for. There are only two paragraphs in the article that are about a test week that has already concluded, but there’s a(nother) link to a wiki page, which I click.

The wiki page provides information about who was participating in that test day, what the prerequisites were, more info about downloading koji (do I need this if i’m doing the bootable image? Is this how I get the bootable image?), details about downloading and installing the kernel (but I just want the bootable image. . .) and how to actually run the test (with another link to the test case).

I scroll back to the top and start reading through everything again when I notice a link under “Prerequisites” that takes me to a page where I can download something called “kerneltest-6.2.2.iso”, which I assume is what I’d need to write to a bootable USB?

Again, I know this is off topic, but it shouldn’t be so complex for even a 15-year veteran user of Fedora to participate. Why isn’t there a single page that says “Here’s when kernel test days are scheduled, here’s where you can download the bootable image, here’s what to do once you boot the live image, and here’s how to report your results”? It feels like all of this information is currently spread across several different sites detailing several different methods of performing the testing, and it’s not clear exactly which steps apply to which testing method.

For a little added complexity, it looks like the wiki page is specific to that week’s kernel test, so it’s not even like I can check back to see when the next one is going to be. How can I get notified that a test day has been scheduled without checking Fedora Magazine every day?

I’m sure I must appear myopic and clueless to someone who is involved in the community on a regular basis. I’d really like to be able to participate and help make my favorite OS even better, if only there were a simple and straightforward way to do so. If you have helpful tips for participating, I’d be happy to continue this conversation elsewhere to keep things on-topic here.


1 Like

I have a similar problem with kernel 6.2.7-200. I can boot, but when I try to login the computer freezes completely.
I had to use the Grub entry to boot with 6.1.18-200


Laptop Dell Precision 7560
CPU: 11th Gen Intel® Core™ i9-11950H × 16
Graphics: Software Rendering / Mesa Intel® UHD Graphics (TGL GT1)
OS: Fedora Linux 37 (Workstation Edition)
Windowing System: Wayland

Hi @coruja182 , I don’t think your problem is the same as what we’re describing here–it sounds more like this:

Hope that helps.

1 Like

I had the exact same issue, last kernel that worked was 6.1.14, fixed by upgrading the BIOS on my ASRock A320M-DGS to the latest version.

Upgrading the BIOS does not work for this.

However, Kernel 6.2.11 is working on my machine.