Fedora 37 - After kernel 6.1.5/6.1.6 update, boot freezes


I’m using Fedora 37 KDE with kernel 6.0.18 and when I tried to update do 6.1.5, the boot don’ t complete, it stay stucked before ask the LUKS password to decrypt the disk.After some minutes waiting, I rebooted and needed to boot in the previous kernel and do a dnf rollback. I waited to see if a new kernel version would be avaiable and tried again with the kernel 6.1.6 and the same behavior happens.

i have an Nvidia GPU using the DRM driver, installed with RPMFusion, with entries in GRUB to black list nouveau and use DRM driver. The new kernel entry has this lines too. I’m providing my <inxi -Fz> output:

  Kernel: 6.0.18-300.fc37.x86_64 arch: x86_64 bits: 64 Console: pty pts/1
    Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: Gigabyte model: B550M AORUS ELITE v: x.x serial: N/A
    UEFI: American Megatrends LLC. v: F14 date: 01/04/2022
  Info: 6-core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 2450 min/max: 2200/4650 cores: 1: 3700 2: 2200 3: 2200
    4: 3700 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] driver: nvidia
    v: 525.78.01
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.7 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,vesa gpu: nvidia,nvidia-nvswitch
    resolution: 1: 3840x2160~60Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 525.78.01 renderer: NVIDIA GeForce RTX
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.0.18-300.fc37.x86_64 running: yes
  Sound Server-1: PipeWire v: 0.3.64 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 3.41 TiB used: 1.69 TiB (49.5%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: FALCON size: 476.94 GiB
  ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS240G2G0C-00AJM0
    size: 223.57 GiB
  ID-3: /dev/sda vendor: Western Digital model: WD20EZRX-00D8PB0
    size: 1.82 TiB
  ID-4: /dev/sdb vendor: Seagate model: ST1000DX001-1NS162 size: 931.51 GiB
  ID-1: / size: 79.98 GiB used: 14.65 GiB (18.3%) fs: btrfs dev: /dev/dm-0
  ID-2: /boot size: 487.2 MiB used: 272.1 MiB (55.8%) fs: ext4
    dev: /dev/nvme1n1p5
  ID-3: /boot/efi size: 96 MiB used: 46.1 MiB (48.0%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme1n1p6
  System Temperatures: cpu: 46.5 C mobo: N/A gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 432 Uptime: 7m Memory: 31.25 GiB used: 7.34 GiB (23.5%)
  Shell: Bash inxi: 3.3.24

Thanks for the attention to help me!

1 Like

If it is booting to a black screen then it seems related to the encryption password prompt. as shown on several other posts here.
As a workaround try entering the password into the blank screen then pressing enter. That seems to have worked for some. This thread also has a link to another related thread.



Hello, I am having the same issue but my boot screen freezes at HP OEM boot logo after… its works fine with Kernel 6.0.18 but all version of 6.1 same boot freezing… I am using it on my HP laptop with Intel i3 7th Gen and Integrated graphics with KDE spin.

Processors: 4 × Intel® Core™ i3-7020U CPU @ 2.30GHz
Memory: 11.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620
Manufacturer: HP

1 Like

Experienced same issue. Just did a ‘sudo dnf update’ this morning and rebooted but Kernel 6.1.6-200 won’t boot. I don’t even get to the disk decryption password prompt. It’s just black screen after the initial BIOS screen.

I was able to successfully boot Kernel 6.0.18-300.

Memory: 32 GB
Processor: 11th Gen Intel i7-11700F x 16
NVIDIA GeForce GTX 1660 Ti
Gnome: 43.2
Windows System: Wayland

As mentioned above, try entering your password while it is on the black screen. It works for some.

The problem appears to be related to display of the password prompt on those systems using encryption and supposedly it will be fixed with the release of 6.1.7.


OK, so I rebooted out of 6.0.18 and back into 6.1.6. I didn’t get the black page this time. It froze at the Gigabyte screen that comes up after the boot loader picks the boot image. But it just sat there like normal doing nothing. So I typed in my LUKS password as you suggested, waited, and then it loaded like normal to the user logon screen. So that seems to be the answer. Although where exactly the screen freezes when failing to display the LUKS password prompt may not always be the same.

1 Like

what password you entered, the user password?

I entered my disk encryption (LUKS) password.