Black Screen after updating to 6.1.5-200.fc37 w/NVIDIA Drivers

This morning, I ran my update like normal to see what all was new and installed the latest kernel 6.1.5-200.fc37. I had previously manually installed Nvidia drivers and they were working just fine with Wayland. I noticed this latest kernel version had some Nvidia updates in it, which I hadn’t seen before, which may be why after rebooting and booting into the new kernel, nothing seemed to happen. I keep getting a perpetual black screen.

After this, I went ahead and booted the older 6.0.18 kernel and it worked just like before. I attempted to delete the newer kernel so I could reinstall it and it seemed to work fine. When I rebooted, I noticed the new kernel was still in the grub menu, but the older one (the one that works) was gone…

I tried going into rescue and using it to reinstall the kernel, using sudo dnf reinstall kernel\*, but I am getting a curl error (6) saying that it can’t resolve the host name. I tried to ping to see if I had an internet connection, but I don’t. I am connected to ethernet, but I have never been in a situation where I had to try to boot from the recovery and fix things from the CLI.

Does anybody know of a way that I can reinstall the old kernel (6.0.18), or fix my new kernel (6.1.5)? Any help or advice would be greatly appreciated.


I forgot to mention, I have set a cron job that deletes old kernels and leaves only the latest two. I have now unfortunately realized why Fedora leaves 3 on there.

1 Like

I manually mounted an external drive with a copy of kernel 6.0.18, installed it with dnf and got my machine working again. I also then tried to reinstall the new kernel (6.1.5) and I continue to get the black screen of nothingness. If anybody has any recommendations as to what I could do going forward to fix my latest kernel, I would greatly appreciate it.

You didn’t mention which

you installed. I would expect the 6.1 kernel to require new Nvidia drivers, and some delay before they are available should not be surprising.

1 Like

I did see that the same update came with some nvidia drivers. I don’t know if the ones that come with the update for 6.1.5 conflict with what I already had installed, since those were downloaded and set up independently. Do you think that may be my issue?

To answer your question, I manually installed nvidia driver version 525.78.01. That’s what is currently working correctly with my kernel version 6.0.18 using Wayland on Fedora 37. I’m not sure how to check the new nvidia drivers that came with the 6.1.5 update.

The documents say 525.78.01 is “alpha” quality.

You may be able to turn on messages by removing rhgb quit from the kernel parameters or pressing when the system boots, but the display may stop working when the driver loads.

If you have another system you could try connecting to the “black screen” system with ssh to check for details in dmesg or with journalctl.

You might want to follow Kernel 6.1.* and nvidia driver issues and NVIDIA Open GPU Kernel Issues .

1 Like

I got the a black screen after grub with kernel 6.1 in Fedora 36 too. I installed the Nvidia driver 525.78.01 through RPM Fusion for Fedora 36 Nonfree as a regualr update.

Thank you, I will keep an eye on these posts. It appears some people are able to get 6.1+ working with nvidia 525.78.01, so I don’t know if this is some unique issue with my particular configuration, or if it has something to do with the fact that I’m using Wayland.

Are you running Wayland? It seems some people are able to get 6.1.+ working, according to this post linked by George N. White III.

I didn’t configure my system other than standard fedora settings. It makes no difference if I’m using wayland or xorg. The problem has to be in the Nvidia driver and the kernel 6.1.
The problem for me is that the encryption password promt does not show up (instead black screen). When I type it in blindly, the system boots up fine with kernel 6.1. So it’s not very likely a wayland or xorg issue.

It may show that somewhere, but rpmfusion has already released it for fedora so I doubt it remains as ‘alpha’.

I suspect more that it has to do with your system. I have both the 6.1.5 kernel and nvidia 525.78.1 drivers working properly.
What GPU are you using? Mine is an older GTX 1050 Ti.

1 Like

Mine is a GTX 1660. Should not be the problem. Is your system encrypted? As I said the promt for entering the password does not show up.
This guy has the same problem:


I do not use luks and my drive is not encrypted. I seem to have missed any comment about a password prompt except in the other thread. I simply booted today for the first time into the 6.1.5 kernel and it worked. I have been using the nvidia 525.78.1 driver for about a week with the 6.0.18 kernel.

I got the exact same behaviour, I never get the prompt to unlock the partitions and boot. I have to go back to 6.0.x kernel.

This is my exact problem, now that I got to try it out. I didn’t realize I could just type the password in blindly. So why would the prompt not be displayed but still be functional? I don’t know how graphics cards work, so this is beyond me.

The cron job is not needed if you use the entry in /etc/dnf/dnf.conf :


3 or higher is while changing the kernels a better choice.

You have to search for that in the old topics. It has to do with something like, that the size of the pw window is too big and not shows the pw-filed anymore (reset of resolution or similar).

Thank you for that tip. I didn’t know you could just edit that in dnf.conf. So in regard to the pw window being sized incorrectly, do you happen to know where that can be edited or how it can be reset?

Unfortunately I do not remember. If I do find the topic I will post it here.

1 Like

My PC was not booting too with the latest kernel! Luckily, the old kernels were there. I have now increased the kernel numbers to 4.

1 Like