Kernel 6.1.5 does not boot

I am receiving a perpetual black screen when attempting to boot into Fedora 37 with kernel 6.1.5. I am using Wayland and had previously manually installed nvidia drivers when 37 was still in beta and it has been working great, all the way up to kernel 6.0.18. I can still use the older kernel just fine, but for some reason 6.1.5 will not boot. It doesn’t even make it to the encryption password after grub. Anyone have similar issues?


Me too. Same problem in Fedora 36 with Nvidia. Black screen after grub. Kernel 6.0.18-200 boots fine.

1 Like

Maybe post here since it appears to be the same issue.

1 Like

I am seeing the same issue on my system. Fedora 37, Wayland, nvidia 3000 Series. Motherboard is and AMD B550M based. Tried multiple things, re-install the driver (using latest rpm fusion drivers), reboot. Re-install kernel nothing worked.

Finally downgraded to kernel 6.0.18-300 and things started working again.

I am in a similar boat. Not sure what to do next and thankful for any recommendations.

Did you read the other thread linked just above?
If using encryption it may be a simple workaround to just enter your password on the blank screen.

Apparently this is related to display of the prompt and not preventing the actual password entry.

1 Like

Thanks for that. I will check out that thread and try the workaround.


Yeah, the work around works for me, even on kernel 6.1.6. I believe they’re working on fixing it already though.

UPDATE: good news the workaround works for me. Looking forward to kernel 6.1.7, hopefully, this will fix the issue. Thank you @computersavvy for the recommendation!

Hello, I am having the same issue but my boot screen freezes at HP OEM boot logo after… its works fine with Kernel 6.0.18 but all version of 6.1 same boot freezing… I am using it on my HP laptop with Intel i3 7th Gen and Integrated graphics with KDE spin.

Processors: 4 × Intel® Core™ i3-7020U CPU @ 2.30GHz
Memory: 11.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620
Manufacturer: HP

I had a similar problem. If your disk is encrypted, try typing the password and pressing enter when you get to that screen. That worked for me.