Black screen after login after updating to 6.2.7-200.fc37.x86_64 kernel


The screen goes black and the system freezes after a successful login when using 6.2.7-200.fc37.x86_64 kernel. I do not have any issue if I choose 6.1.18-200.fc37.x86_64 during boot,
The problem appeared after I installed the system updates from last Friday.
I am using X11 with Mesa Intel® Graphics (ADL GT2) / Mesa Intel® Graphics (ADL GT2) and I do not have any nvidia driver installed.

Try switching tty with ctrl + alt + f2 when the screen is black. From there you should be able to check the logs.

If that doesn’t work try using a Wayland session instead, to check if the problem is with X.

Hi @risotto8464,

Thank you for your reply!
I am not able to activate tty because the system freezes, nothing happens when I press ctr + alt + f2.
The same thing happens when I use wayland.
I checked and compared the output of journalctl while booting those 2 kernel versions, but I did not find any particular error. Both versions are printing similar logs.

I see, where you able to check the logs somehow? In that case also check dmesg for errors.

You could install and update fedora on a usb drive, not touching your current install, and check if problem is present on new install aswell.

Since you can boot you might be able to setup an ssh server on your machine, then connect to it and monitor its state and what happens when you sign in from there. Comparing the different kernels booted.

@risotto8464 Thanks again for your support.
I fixed the issue by installing the latest nvidia drivers from RPM fusion. I think there is a problem with the nouveau driver, but I cannot give more detailed information about it. All I have are the following lines logged on startup:
fedora kernel: nouveau 0000:01:00.0: gr: failed to construct context fedora kernel: nouveau 0000:01:00.0: fifo:000000:0002:[gnome-shell[1453]] ectx 0[gr]: -110
I found something similar from the begining on this month [SOLVED]nouveau kernel module black screen after login & battery / Kernel & Hardware / Arch Linux Forums.

No problem and glad you found a solution!

I have a similar problem with kernel 6.2.7-200. I can boot, but when I try to login the computer freezes completely.
I had to use the Grub entry to boot with 6.1.18-200


Laptop Dell Precision 7560
CPU: 11th Gen Intel® Core™ i9-11950H × 16
Graphics: Software Rendering / Mesa Intel® UHD Graphics (TGL GT1)
OS: Fedora Linux 37 (Workstation Edition)
Windowing System: Wayland

HI, same problem here:
For me the following made everything work as it should.

In /etc/default/grub edit GRUB_CMDLINE_LINUX_DEFAULT to the following GRUB_CMDLINE_LINUX_DEFAULT="intremap=off". After that run a sudo update-grub. After a reboot, everything should work fine.

Found solution on:

That is not the proper command for a grub update on a Fedora system.
Use sudo grub2-mkconfig -o /boot/grub2/grub.cfg instead.
Fedora and Ubuntu are somewhat different in how grub is managed.

My system does not have the entry GRUB_CMDLINE_LINUX_DEFAULT.


I tried your fix and my PC still freezes after login, even with the newest Kernel. I still need to run Fedora using the 6.1.X Kernel, unfortunately

I have the same problem and I also do not have that line. Should we edit the existing line line which has GRUB_CMDLINE_LINUX="rhgb quiet" and add ,intremap=off? Or should I replace the current contents? Or should I add the GRUB_CMDLINE_LINUX_DEFAULT line above or below the existing line?

I can verify that 6.2.8-200 and 6.2.9-200 kernels both fail the same way, and 6.1.18-200 works fine.

Should we submit a bug report or has someone already reported this?

You can edit the existing command line and add that option to it. I don’t believe fedora uses the cmdline _DEFAULT entry normally, but other distros may. Note that options are separated by white space only and do not use a comma on that line.

Only remove the rhgb quiet portion if you wish to have the boot messages scroll on the screen while booting.

1 Like

I finally rebooted and I still have the problem.

I see Fedora 38 is now available. Do you think the problem is resolved there? If not, how do I save kernel 6.1.18-200 in case?

I see we have not gotten detailed info on your hardware.
Please post the output of inxi -Fzxx so we can see all the hardware.

Kernel: 6.1.18-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.38-25.fc37 Desktop: GNOME v: 43.4 tk: GTK v: 3.24.37 wm: gnome-shell
dm: GDM Distro: Fedora release 37 (Thirty Seven)
Type: Laptop System: LENOVO product: 20YQCTO1WW v: ThinkPad P15 Gen 2i
serial: Chassis: type: 10 serial:
Mobo: LENOVO model: 20YQCTO1WW v: SDK0J40697 WIN
serial: UEFI: LENOVO v: N37ET44W (1.25 )
date: 02/08/2023
ID-1: BAT0 charge: 84.0 Wh (100.0%) condition: 84.0/94.0 Wh (89.4%)
volts: 12.9 min: 11.5 model: Celxpert 5B10W13959 serial:
status: full
Info: 8-core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
Speed (MHz): avg: 1152 high: 2300 min/max: 800/4600 cores: 1: 1094 2: 1261
3: 843 4: 1281 5: 801 6: 799 7: 1067 8: 1262 9: 792 10: 1237 11: 1330
12: 2300 13: 1191 14: 1127 15: 963 16: 1092 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1, DP-2, DP-3,
DP-4, DP-5, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a60
Device-2: NVIDIA TU117GLM [T1200 Laptop GPU] vendor: Lenovo
driver: nouveau v: kernel arch: Turing pcie: speed: 16 GT/s lanes: 8 ports:
active: none empty: DP-6, DP-7, DP-8, HDMI-A-2, eDP-2 bus-ID: 01:00.0
chip-ID: 10de:1fbc temp: 42.0 C
Device-3: Luxvisions Innotech Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-4:3 chip-ID: 30c9:003a
Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9
compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
dri: iris gpu: i915 display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1520 res: 1920x1080 dpi: 142
diag: 394mm (15.5")
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel UHD Graphics (TGL GT1)
direct-render: Yes
Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo
driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:10fa
API: ALSA v: k6.1.18-200.fc37.x86_64 status: kernel-api
Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
pcie: speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
IF: wlp9s0 state: up mac:
Device-2: Intel Ethernet I225-V vendor: Lenovo driver: igc v: kernel pcie:
speed: 5 GT/s lanes: 1 port: N/A bus-ID: 0b:00.0 chip-ID: 8086:15f3
IF: enp11s0 state: down mac:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:5 chip-ID: 8087:0032
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Local Storage: total: 476.94 GiB used: 60.47 GiB (12.7%)
ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKBA512TFH size: 476.94 GiB
speed: 63.2 Gb/s lanes: 4 serial: temp: 38.9 C
ID-1: / size: 298.89 GiB used: 60.14 GiB (20.1%) fs: btrfs
dev: /dev/nvme0n1p6
ID-2: /boot size: 973.4 MiB used: 276.2 MiB (28.4%) fs: ext4
dev: /dev/nvme0n1p5
ID-3: /boot/efi size: 256 MiB used: 66.1 MiB (25.8%) fs: vfat
dev: /dev/nvme0n1p1
ID-4: /home size: 298.89 GiB used: 60.14 GiB (20.1%) fs: btrfs
dev: /dev/nvme0n1p6
ID-1: swap-1 type: zram size: 8 GiB used: 9.7 MiB (0.1%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 52.0 C mobo: N/A gpu: nouveau temp: 42.0 C
Fan Speeds (RPM): fan-1: 1987 fan-2: 1839
Processes: 543 Uptime: 14d 19h 37m Memory: 31.06 GiB used: 13.64 GiB (43.9%)
Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 2
Shell: Bash v: 5.2.15 running-in: gnome-terminal inxi: 3.3.26

It would appear that you have one of the newer GPUs in that machine (RTX/Quadro series) and that you are using the nouveau (open source) drivers.

It is known that nouveau does not, as yet, support those GPUs properly. I would suspect that if you were to install the nvidia drivers from rpmfusion that the problem with the 6.2.X series of kernel would be solved.

Thanks Jeff. I’ll give that a shot. I can’t follow their recommended first step to update the kernel first.

Why not? What happens when you try dnf upgrade? This is actually what should be done as the first step.

Edit: I understand that you cannot boot into the newer kernel, but it could be installed so the drivers are built for it.

I assume you are booting to the 6.1.18 kernel. Boot to that kernel, remove the other 6.2.x kernels with dnf remove 'kernel*6.2.*' then run the upgrade dnf upgrade. This will keep your 6.1.18 kernel installed and install the newest 6.2 kernel, and can all be done before the initial reboot.
If the reboot still gives the black screen with the 6.2 kernel then boot to the 6.1.18 kernel and follow the remaining steps to install the nvidia drivers.