Kernel-5.2.5-200.fc30.x86_64 black screen after login

After upgrade to kernel-5.2.5-200.fc30.x86_64 on a ASRock B450M Pro4 with AMD ryzen 5 ‘Raven Ridge’ running an Xfce environment I always have to boot from any older kernel version available to login. When starting from kernel-5.2.5-200.fc30.x86_64 I see the login screen, but after login I only get a black screen, nothing works anymore, not even Ctrl - Alt - F1, and I need to force power off using the power button. Starting from any older kernel version works normally. When logged in from an older kernel a whole list if error notifications appear on the screen, but there isn’t enough information to file a bug report.
After the upgrade to kernel-5.2.6-200.fc30.x86_64 today the issue remains the same, so I only have one older kernel 5.1 left to boot the system. The only way booting a recent kernel version is Ctrl Alt F1 on the login screen, login in the virtual console and type startx to start the Xfce environment.

Same problem here, I also get only a black screen after the login. I tried it with the same kernel versions as peterjmb, but the last working kernel is 5.1 (5.1.20-300.fc30.x86_64 in my case).
Software: Fedora 30 with Xfce
Hardware: Lenovo T495 with AMD Ryzen 7 Pro 3700U

from gnome-abrt notification, and the very long but unsufficient text in the problem report, sorry cannot upload it as .pdf here, text that tells me as an average Linux user it is only bootable in kernel version 5.1 and not in version 5.2, what I already knew. Hope some Fedora or Red Hat developer can fix this. Sorry for the very long text, but it is not possible to file a bug report as the screenshots tell:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 43 bits physical, 48 bits virtual
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 2
Core(s) per socket: 4
Socket(s): 1
NUMA node(s): 1
Vendor ID: AuthenticAMD
CPU family: 23
Model: 17
Model name: AMD Ryzen 5 2400G with Radeon Vega Graphics
Stepping: 0
CPU MHz: 3207.430
CPU max MHz: 3600.0000
CPU min MHz: 1600.0000
BogoMIPS: 7186.05
Virtualization: AMD-V
L1d cache: 32K
L1i cache: 64K
L2 cache: 512K
L3 cache: 4096K
NUMA node0 CPU(s): 0-7
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme ssbd sev ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca

ip6t_rpfilter 16384 1 - Live 0xffffffffc0a47000
ip6t_REJECT 16384 2 - Live 0xffffffffc0a3f000
nf_reject_ipv6 20480 1 ip6t_REJECT, Live 0xffffffffc0a39000
ipt_REJECT 16384 2 - Live 0xffffffffc0a31000
nf_reject_ipv4 16384 1 ipt_REJECT, Live 0xffffffffc0a2c000
xt_conntrack 16384 13 - Live 0xffffffffc0a24000
ebtable_nat 16384 1 - Live 0xffffffffc0a1c000
ip6table_nat 16384 1 - Live 0xffffffffc0a17000
ip6table_mangle 16384 1 - Live 0xffffffffc0a0f000
ip6table_raw 16384 1 - Live 0xffffffffc0942000
ip6table_security 16384 1 - Live 0xffffffffc0a0a000
iptable_nat 16384 1 - Live 0xffffffffc0a02000
nf_nat 49152 2 ip6table_nat,iptable_nat, Live 0xffffffffc09f5000
iptable_mangle 16384 1 - Live 0xffffffffc0935000
iptable_raw 16384 1 - Live 0xffffffffc092d000
iptable_security 16384 1 - Live 0xffffffffc093d000
nf_conntrack 151552 2 xt_conntrack,nf_nat, Live 0xffffffffc09cf000
nf_defrag_ipv6 24576 1 nf_conntrack, Live 0xffffffffc0926000
nf_defrag_ipv4 16384 1 nf_conntrack, Live 0xffffffffc091e000
libcrc32c 16384 2 nf_nat,nf_conntrack, Live 0xffffffffc08f7000
ip_set 53248 0 - Live 0xffffffffc08e9000
nfnetlink 16384 1 ip_set, Live 0xffffffffc08b2000
ebtable_filter 16384 1 - Live 0xffffffffc08ad000
ebtables 40960 2 ebtable_nat,ebtable_filter, Live 0xffffffffc089e000
ip6table_filter 16384 1 - Live 0xffffffffc0899000
ip6_tables 32768 7 ip6table_nat,ip6table_mangle,ip6table_raw,ip6table_security,ip6table_filter, Live 0xffffffffc0847000
iptable_filter 16384 1 - Live 0xffffffffc083f000
ip_tables 32768 5 iptable_nat,iptable_mangle,iptable_raw,iptable_security,iptable_filter, Live 0xffffffffc082a000
sunrpc 450560 1 - Live 0xffffffffc0960000
edac_mce_amd 32768 0 - Live 0xffffffffc08bc000
wmi_bmof 16384 0 - Live 0xffffffffc0728000
kvm_amd 106496 0 - Live 0xffffffffc087e000
snd_hda_codec_realtek 126976 1 - Live 0xffffffffc08c9000
ccp 98304 1 kvm_amd, Live 0xffffffffc0865000
snd_hda_codec_generic 90112 1 snd_hda_codec_realtek, Live 0xffffffffc0949000
ledtrig_audio 16384 2 snd_hda_codec_realtek,snd_hda_codec_generic, Live 0xffffffffc01e5000
snd_hda_codec_hdmi 65536 1 - Live 0xffffffffc0854000
kvm 749568 1 kvm_amd, Live 0xffffffffc0770000
snd_hda_intel 49152 2 - Live 0xffffffffc0248000
snd_hda_codec 155648 4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel, Live 0xffffffffc073c000
snd_hda_core 102400 5 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec, Live 0xffffffffc06fe000
irqbypass 16384 1 kvm, Live 0xffffffffc06ce000
snd_hwdep 16384 1 snd_hda_codec, Live 0xffffffffc01d6000
snd_seq 86016 0 - Live 0xffffffffc06dd000
snd_seq_device 16384 1 snd_seq, Live 0xffffffffc01c5000
snd_pcm 118784 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core, Live 0xffffffffc06b0000
joydev 28672 0 - Live 0xffffffffc0180000
sp5100_tco 20480 0 - Live 0xffffffffc025d000
snd_timer 40960 2 snd_seq,snd_pcm, Live 0xffffffffc023d000
i2c_piix4 28672 0 - Live 0xffffffffc01ce000
k10temp 16384 0 - Live 0xffffffffc017b000
snd 94208 14 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer, Live 0xffffffffc0196000
soundcore 16384 1 snd, Live 0xffffffffc0146000
gpio_amdpt 20480 0 - Live 0xffffffffc0175000
gpio_generic 16384 1 gpio_amdpt, Live 0xffffffffc06d8000
pcc_cpufreq 20480 0 - Live 0xffffffffc06f8000
acpi_cpufreq 28672 0 - Live 0xffffffffc00ef000
dm_crypt 53248 1 - Live 0xffffffffc0167000
amdgpu 3989504 2 - Live 0xffffffffc02e1000
i2c_algo_bit 16384 1 amdgpu, Live 0xffffffffc01c0000
chash 16384 1 amdgpu, Live 0xffffffffc01b0000
gpu_sched 36864 1 amdgpu, Live 0xffffffffc01db000
amd_iommu_v2 20480 1 amdgpu, Live 0xffffffffc013e000
ttm 114688 1 amdgpu, Live 0xffffffffc0220000
crct10dif_pclmul 16384 1 - Live 0xffffffffc018b000
drm_kms_helper 217088 1 amdgpu, Live 0xffffffffc01ea000
crc32_pclmul 16384 0 - Live 0xffffffffc0162000
crc32c_intel 24576 7 - Live 0xffffffffc0134000
drm 503808 6 amdgpu,gpu_sched,ttm,drm_kms_helper, Live 0xffffffffc0265000
ghash_clmulni_intel 16384 0 - Live 0xffffffffc012f000
r8169 90112 0 - Live 0xffffffffc014b000
wmi 36864 1 wmi_bmof, Live 0xffffffffc01b6000
video 49152 0 - Live 0xffffffffc0122000
pinctrl_amd 32768 0 - Live 0xffffffffc0115000

Had to remove dmesg:
success: 0
fail: 0
failed_freeze: 0
failed_prepare: 0
failed_suspend: 0
failed_suspend_late: 0
failed_suspend_noirq: 0
failed_resume: 0
failed_resume_early: 0
failed_resume_noirq: 0

last_failed_errno: 0

This is what I am looking for:
Where is the archive of the old Ask Fedora?
Need to downgrade the kernel persistently and prevent it from updating. Too much “alfa” is not a good thing, Fedora!

And of course remove the updates repostory, The old “Ask Fedora” had much more valuable info.



should do

=> man dnf.conf

Have a look to these posts:


However you have an issue that should be investigated.
Let me understand: if you boot kernel-5.2, the graphical login screen appears, but once logged in the desktop stays black. If you boot kernel-5.2, and you go to a virtual console (ctrl+alt+F1), then you log in and you issue startx, Xfce start normally?

P.S. Fedora is not alpha. It is a characteristic of Fedora to provide updates at a relatively fast pace, and it is a reason why many people use it. But it is a myth that Fedora is a bleeding edge distribution. It is difficult that you will find alpha or unstable software. Same thing for the kernel. But software is software, and has bugs; something that works for me could go wrong in your environment. And since we use free software and such software is supported by a community, we have the possibility to file bugs, we can help each other, we can contribute to solve problems.

1 Like

Not for me. If I boot kernel-5.2, press Ctrl Alt F3 (F1 is the graphical interface on my system) on the login screen and run startx, then I can see the Xfce desktop for a few seconds and then get a black screen again. But that may be an additional error on my system if that way is working for peterjmb. Unfortunately I also have no report-able errors in the Problem Reporting app.

As we both have an error in the logs about the amdgpu driver - could it probably be an incompatibility between the amdgpu driver and kernel-5.2?

Edit: I tried to remove xorg-x11-drv-amdgpu from my system, but that didn’t make a difference with kernel-5.2.6. However, I found out that the way via another terminal and startx would work for me too if I use only the internal display and no additional external display, but I see a lot of screen artifacts in areas with recently refreshed content.

@alciregi and @zookhra it isn’t Xfce or Amd, it seems to be Samsung:
Samsung SSD EVO is the disk I use Fedora on.
But I still can boot it from kernel 5.1

I’m not so sure that that is the real problem source. I also have a Samsung SSD (MZVLB512HBJQ) in my system, but I don’t see any ATA or DRDY errors in /var/log/messages.

However, I decided to switch back to Arch. Interestingly I hadn’t the problem after the set up (Xfce 4.13 and kernel 5.2.x), but the same problem started when I updated my system to Xfce 4.14 when it was released. The solution was to disable the option “Display fullscreen overlay windows directly” in the Window Manager Tweaks/Compositor before the update. Maybe this will help you too. As a first check you can try to disable compositing in Xfce. That can be done via the terminal too: xfconf-query -c xfwm4 -p /general/use_compositing -s false.

1 Like

It is the kernel, and only the kernel. Tried it out in other Linux with Mate GUI on another computer, the same: Old kernel version works, starting from kernel version 5.2 exactly the same problem: frozen black screen after login, no cursor or whatever, have to forcefully power-off and start from older kernel that works. Screenshots from Fedora after starting from kernel 5.1 about system failure that cannot be reported and the last screenshot from terminal in /var/spool/abrt, a whole bunch of the same. This isn’t funny anymore. The developers have to fix their kernel, which probably will only work on some computers but on none of mine!

Bug 1742960
Similar to

Somebody found a temporary solution! See comment 26 in this bug report:

Create a shell script at /etc/profile.d/ and add export AMD_DEBUG=nodcc to it. Next, run chmod +x /etc/profile.d/ to add execution permissions. The next time you boot with a 5.2.X kernel, everything should work normally.

I tested this on a Lenovo T495 with AMD Ryzen Pro 3700U running Fedora 30 (kernel 5.2.9) with XFCE.

Edit: Fixed missing text in the script.

Notice: I unmarked the previously marked solution, since it wasn’t the solution.

It’s a (possible?) workaround, not a solution, but it can be still quite useful to people suffering from this, so thanks @blazin64 for sharing this!

It would be great if some of the people bitten by this bug could try this and report if it help them as well.

And by the way, @blazin64, welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so. ))

1 Like

I should’ve been clearer—another post on “locking kernel versions” was marked as a solution, so I unmarked it. @blazin64’s post is much nearer to the solution.

1 Like

Note, that executable bit is redundant for the files in /etc/profile.d/.


There is no solution until the day the developers rewrite the kernel.
Just tested kernel-5.2.11-200.fc30.x86_64
The problem remains.

Thank you for the “turn off compositing” hint, and the command line! I have the same issue on a ThinkPad T495s (Ryzen 7 Pro 3700U).

In fact I have had this issue for almost half a yr on my Ryzen 5 2400G desktop also! I have been keeping around a 4.x series kernel just to keep it bootable.

I wonder what’s the right channel to report to the devs, I have filed bug reports on the RedHat bugzilla regularly, but that has gathered dust (as in, not a single dev/maintainer commenting on it) every time it has been a kernel issue (other reports have received reasonable attention).

Reporting Bugs (
But distro maintainers probably need to be notified too.

1 Like