Kernel panic after upgrade to 37.20230315.0

You can see a lot of firmware with fwupdmgr get-devices — in the case of my desktop, it even lists firmware that it finds that isn’t supported. (It might or might not have the version that’s shown on the website for manually updating the firmware.)

If your hardware is supported (my desktop isn’t, but laptop is), then fwupdmgr update will help you update it.

$ fwupdmgr get-devices
WARNING: UEFI firmware can not be updated in legacy BIOS mode
See for more information.
System manufacturer System Product Name
├─300 Series Chipset SATA Controller:
│     Device ID:          7d29f2075dcafb4488b40c73f199cf46bb76bddb
│     Current version:    02
│     Vendor:             Advanced Micro Devices, Inc. [AMD] (PCI:0x1022)
│     GUIDs:              17f97e61-e971-53d5-bb9e-6bcef9c6c23f ← PCI\VEN_1022&DEV_43B7
│                         ef4a96a0-45d1-5cff-90d3-e6f387d130e7 ← PCI\VEN_1022&DEV_43B7&REV_02
│                         8b139035-0f55-5b27-b1bc-c2c0064addd4 ← PCI\VEN_1022&DEV_43B7&SUBSYS_1B211062
│                         2752f8e3-f453-5b2c-b26e-fbe10c23be07 ← PCI\VEN_1022&DEV_43B7&SUBSYS_1B211062&REV_02
│                         1d3e715a-7904-528d-8c2f-ae4648e476e7 ← PCI\VEN_1022&DEV_1453
│                         3c5c9a8d-93bc-592a-b193-1f8a742dca36 ← PCI\VEN_1022&DEV_1453&REV_00
│                         ca12abed-f939-51d2-83cd-3537ffd291e3 ← PCI\VEN_1022&DEV_1453&SUBSYS_10438747
│                         02100450-4f5b-5ada-9c7b-2806ccde0d3c ← PCI\VEN_1022&DEV_1453&SUBSYS_10438747&REV_00
│     Device Flags:       • Internal device
│                         • Cryptographic hash verification is available
├─AMD Ryzen 5 1400 Quad-Core Processor:
│     Device ID:          4bde70ba4e39b28f9eab1628f9dd6e6244c03027
│     Current version:    0x08001138
│     Vendor:             Advanced Micro Devices, Inc.
│     GUIDs:              b9a2dd81-159e-5537-a7db-e7101d164d3f ← cpu
│                         997104da-ec11-5e04-9d94-ac5501fbf609 ← CPUID\PRO_0&FAM_17
│                         5fa201c0-e152-5003-a56b-93a9dd683fc7 ← CPUID\PRO_0&FAM_17&MOD_01
│                         0eab26c9-612c-5655-957c-6a4bec51e214 ← CPUID\PRO_0&FAM_17&MOD_01&STP_1
│     Device Flags:       • Internal device
│     Device ID:          9afcd7db8643d511ee389321038ae4c56c7a45f3
│     Summary:            ATA drive
│     Current version:    GF100-07
│     Vendor:             Samsung (ATA:0x144D, OUI:0000f0)
│     Serial Number:      S0V3J9CQ715781
│     GUIDs:              a6520ca8-2f92-52e8-a911-d7843604853f ← IDE\SAMSUNG_HD161HJ_________________________GF100-07
│                         026faef4-2a1d-5f07-ada1-7284f8dbaf17 ← IDE\0SAMSUNG_HD161HJ_________________________
│                         7cde58b9-1b94-5063-8360-b9dc69c66071 ← SAMSUNG HD161HJ
│     Device Flags:       • Internal device
│                         • Updatable
│                         • System requires external power source
│                         • Needs a reboot after installation
│                         • Device is usable for the duration of the update
├─Hitachi HCS721010CLA332:
│     Device ID:          26856ad5cbbaecc7579ecb42c8a409dbe14e936b
│     Summary:            ATA drive
│     Current version:    JP4OA3EA
│     Vendor:             Western Digital (ATA:0x101C, OUI:000cca)
│     Serial Number:      JP9960HZ1PBAEU
│     GUIDs:              4d781e62-0c7c-5c97-911b-ee4f2498b1c4 ← IDE\Hitachi_HCS721010CLA332_________________JP4OA3EA
│                         325d29fc-aa2a-52b3-8388-fc018d9be5aa ← IDE\0Hitachi_HCS721010CLA332_________________
│                         a1719ebe-ec03-592c-8122-3c2deeea097a ← Hitachi HCS721010CLA332
│     Device Flags:       • Internal device
│                         • Updatable
│                         • System requires external power source
│                         • Needs a reboot after installation
│                         • Device is usable for the duration of the update
│     Device ID:          c6a80ac3a22083423992a3cb15018989f37834d6
│     Summary:            TPM 2.0 Device
│     Current version:
│     Vendor:             Advanced Micro Devices, Inc. (TPM:AMD)
│     GUIDs:              ff71992e-52f7-5eea-94ef-883e56e034c6 ← system-tpm
│                         9305de1c-1e12-5665-81c4-37f8e51219b8 ← TPM\VEN_AMD&DEV_0001
│                         78a291ae-b499-5b0f-8f1d-74e1fefd0b1c ← TPM\VEN_AMD&MOD_AMD
│                         65a3fced-b423-563f-8098-bf5c329fc063 ← TPM\VEN_AMD&DEV_0001&VER_2.0
│                         5e704f0d-83cb-5364-8384-f46d725a23b8 ← TPM\VEN_AMD&MOD_AMD&VER_2.0
│     Device Flags:       • Internal device
└─Vega 10 XL/XT [Radeon RX Vega 56/64]:
      Device ID:          d05d536fa7bd6811a229e6b6e896497fa3cf1084
      Current version:    xxx-xxx-xxx
      Vendor:             Advanced Micro Devices, Inc. [AMD/ATI] (PCI:0x1002, PCI:0x1022)
      GUIDs:              887634ce-5760-54fe-8b49-89d905716eb5 ← PCI\VEN_1002&DEV_687F
                          3e5dccc2-9f56-5b7a-8778-30e98f64c3e2 ← PCI\VEN_1002&DEV_687F&REV_C1
                          787b837f-8ac5-507c-bd34-ff729ec533ec ← PCI\VEN_1002&DEV_687F&SUBSYS_14582308
                          78fcc526-29ac-5ea5-a401-5d386396d0b1 ← PCI\VEN_1002&DEV_687F&SUBSYS_14582308&REV_C1
                          83774004-d23a-5f43-a56b-a7693934dfb6 ← PCI\VEN_1022&DEV_1471
                          f6d469bc-28cc-5c0c-aaae-07ca05ae3027 ← PCI\VEN_1022&DEV_1471&REV_00
                          f1fbe3ed-78eb-5a91-acea-c7d7c5931eb5 ← PCI\VEN_1022&DEV_1471&SUBSYS_10221471
                          2dce2b4b-a226-5ed9-afc3-26517ab459c4 ← PCI\VEN_1022&DEV_1471&SUBSYS_10221471&REV_00
      Device Flags:       • Internal device
                          • Cryptographic hash verification is available

Just got the 37.20230322.0 update; no change, kernel panic persists:

ASUS still only offering beta version of the 6061 bios for the PRIME B350M-A motherboard.

Just got the 37.20230426 update: no change, kernel still panics.

Found out Asus PRIME B340M-A BIOS is 6042 dated 2022-04-28.

I’m having the same error message when trying to boot Fedora 37 (not Silverblue) with kernels 6.1.18 and 6.2.7. Kernel 6.1.15 works. This is with a Gigabyte A320M-HD2 motherboard, and happens even after updating the BIOS to the newest available version.

Same here. I originally skipped past this thread because I’m not running Silverblue, but I’ve got two systems on F37 Workstation that can’t boot either 6.1.18 or 6.2.7. I haven’t done any BIOS updates, but from what Nebbie Zebbie is saying, it doesn’t sound like it makes a difference anyway.

inxi output:

$ inxi -CMSG
  Host: toolbox Kernel: 6.1.14-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: ASUSTeK model: PRIME B350M-A v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 6042
    date: 04/28/2022
Use of uninitialized value $value[0] in string ne at /usr/bin/inxi line 9227.
Use of uninitialized value $value[0] in string ne at /usr/bin/inxi line 9227.
  Info: quad core (2-mt/2-st) model: AMD Ryzen 5 1400 bits: 64 type: MST AMCP
    cache: L2: 2 MiB
  Speed (MHz): avg: 1622 min/max: 1550/3200 cores: 1: 1550 2: 1375 3: 1550
    4: 1550 5: 1272 6: 2437
  Device-1: AMD Vega 10 XL/XT [Radeon RX 56/64] driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 22.1.8 compositor: gnome-shell driver:
    dri: radeonsi gpu: amdgpu resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: AMD Radeon RX Vega (vega10 LLVM
    15.0.7 DRM 3.49 6.1.14-200.fc37.x86_64)

Ah, that info there is helpful. I think Chris’ GPU speculation can be ruled out, as I have a GTX 1060; the consistent thing is Ryzen 1st gen CPUs (I have a Ryzen 5 1500X).

Kernel panics in the 37.20230401 update.

Kernel panics in the 37.20230402 update.

Just thought I would share my findings on this topic. I am running a Ryzen 1500x and GTX 1050 ti, I was experiencing kernel panics with the later 6.1.x and all of the 6.2.x kernels.

I managed to fix the issue by compiling a custom 6.2.9 kernel using the patch mentioned here

1 Like

Thanks for that update, Lenard.

It would seem the cause of the problem is identified.

I can see the patch has made it way into version 6.3 rc 5 of the kernel. Hopefully when the 6.3 kernel is released this will be resolved.

Thank you for that update, Lenard; very promising.

From uname -a I see I am on fedora 6.1.14-200.fc37.x86_64.

Maybe there is retroactive patch application?

And just for the record:

Kernel panics in the 37.20230409 update.

I am on F37 Workstation, Just updated to the 6.2.9 kernel and first boot I got a kernel panic.
I did a forced power off then back on and it booted properly.
Have you tried a second boot after the kernel panic halt?

I tried it; alas, no joy.

For those who cannot wait you can download the 6.2.11 kernel files from here for Fedora 37. See command below for a list of files to download, working on my Ryzen 1500x.

Then run the following from the download folder

sudo rpm -i ./kernel-6.2.11-200.fc37.x86_64.rpm ./kernel-core-6.2.11-200.fc37.x86_64.rpm ./kernel-modules-6.2.11-200.fc37.x86_64.rpm ./kernel-devel-6.2.11-200.fc37.x86_64.rpm ./kernel-modules-core-6.2.11-200.fc37.x86_64.rpm 

Nice work, Lenard.

Do you know if this will work for Fedora Silverblue?

And, just for the record (again):

Kernel panics in the 37.20230414 update.

The only way I know to do this on Silverblue is to rebase to the testing branch which has the 6.2.11 kernel. It worked when I tested it in a VM, not sure what the stability would be like.

rpm-ostree rebase fedora/37/x86_64/testing/silverblue

Kernel booted! in the 37.20230601.0 update.

Kernel (per uname -a) is 6.3.4-101.fc37.x86_64