Fedora won't boot since kernel 6.2.*

I’m running Fedora 37 with kernel-6.1.18-200.fc37.x86_64 and since kernel (and kernel-core) updates to 6.2 (6.2.7 / 6.2.8 / 6.2.10), when I chose a 6.2.* version in the grub boot menu, the computer freezes and does not react anymore.
I don’t understand the problem and i don’t have any errors on boot screen.
I have to start fedora with kernel 6.1.18 and that’s actually annoying…
Any ideas ? Thanks a lot…

(PC specs : Laptop HP HP ZBook Firefly 14 inch G8 Mobile Workstation PC / 11th Gen Intel® Core™ i7-1165G7 × 8 / Mesa Intel® Xe Graphics (TGL GT2) / Mesa Intel® Xe Graphics (TGL GT2))

You need to collect logs to find out what’s going wrong.

First boot the latest 6.2 kernel, reboot into the working 6.1 kernel and read logs from the previous (failed) boot attempt. (journalctl -b -1). For more information about reading log files, see Viewing logs in Fedora :: Fedora Docs and maybe View and Analyze Systemd Logs Using Journalctl [Complete Guide]


I have “nouveau” driver errors, I have the impression that the problem comes from there… but I don’t really know how to solve this problem. I’m searching

Paste the full log, or at least the lines that could tell something about the issue.

nouveau? Do you have an nvidia graphics adapter?

Hi, I do have the same problem, I posted a request earlier but no answers so far.

My one year old Ryzen Desktop machine does not boot after upgrading to 6.2.x so I went back to 6.1.8.
By the way this issue happens only on my desktop, the other machines are laptops and work fine with Fedora and the 6.2.x

There are 5 profiles for HP HP ZBook Firefly 14 inch G8 Mobile Workstation PC at Linux Hardware.org, all mention Nvidia, e.g. Probe 603ccdfb84 has TU117GLM [Quadro T500 Mobile].

Arch Linux report for nouveau blackscreen with TU117GLM [Quadro T500 Mobile].

1 Like

Reference: Fedora Kernel issue on Ryzen processor machine

logs? nvidia graphics card?

Thanks for your enquiry.

Could you tell me how I can get that log? I mean, something like journalctl -b -1?

I don’t upgrade the system anymore because I am afraid of not being able to go back again to 6.1.8 due to the fact that the grub shows 2 previous versions only… and I’ve already upgraded and downgraded twice…

I’ve forgotten:
16.0 GiB
AMD Ryzen™ 5 2600X × 12

Fedoras update process never replaces the running kernel. If you are booted into the 6.1.18 kernel when you do the update that kernel should remain and one of the newer kernel be replaced with a kernel upgrade.

The nouveau drivers are open source, reverse engineered, and do not fully (if at all) support the newer GPUs. Depending upon which GPU and kernel is installed it is quite possible that the nouveau driver may not function. Installing the nvidia driver from rpmfusion does provide support for the newer GPUs (the driver is built for each kernel when it is installed).


There are many reports of systems booting to a blank screen, which is probably a graphics problem. In such cases, you may be able to get a terminal by entering <Ctrl-Alt> N, where N=2, 3, or 4. Pressing escape when the system starts to boot may let you see kernel messages. From the grub menu you can edit the kernel command-line to remove “rhgb quiet” to see the messages.

In a terminal: man journalctl. A problem with journalctl is that the lines can be very long. On strategy is to run journalctl and scan for messages related to a problem and select a string specific to the problem. The capture those lines in a file:

$ journalctl -b N | grep string_specific_to_the_problem > string_specific_to_the_problem.txt

You then edit and annotate the file and paste into a forum post (bracketed with triple backquotes).

See: pin or retain a kernel version.

There is an LTS 6.1 Kernel available:
kwizart/kernel-longterm-6.1 Copr

If you install it this way it will not be overwritten. It is not the same repository. You can increase the value of maintaining kernel to 4 so you have 2 versions of both.

@gnwiii mentinoed journalctl here an article about it I saw today:

At the moment I went for the long term due to the fact that I am doing some important jobs and I cannot risk long debugging.
I will try to update Fedora only when my job is done and then will see.
Meanwhile I will follow this discussion becuse the problem is not solved yet
For now thanks a lot

I got the same problem on my ThinkPad T14 (2 gen) no 6.2.x kernel works for me; it’s frustrating because i cant upgrade the new release fedora 38; the usb installer not boot … my only soption in this moment is to stay on Kernel 6.1.X.

1 Like

the issue i think come from gnome.
because i had same thing after kernel 6.2.x when i tried kde it works normally but with gnome pc tries to run some service related to gnome and hang their

same thing with thinkbook
try kde until they fix the bug

remove them and keep the stable one and keep trying upgrade for new ones
sudo dnf list --installed | grep kernel
then remove them like this
sudo dnf remove kernel-core-6.2.10-200.fc37

Type of logs i have in journalctl when i have the freeze after selecting grub kernel version 6.2.*

That image shows that the nouveau driver is unable to load the firmware for your GPU, and that probably is the cause of the errors.

Please provide the output of inxi -Fzxx so we can see the actual device.

1 Like

Your image truncates long text lines. When posting excerpts from journactl it is better to paste text bracketed with lines of 3 backtics.

You appear to have both i915 and Nvidea graphics. Failure of the driver for Nvidea hardware should fall back to i915 so the system still boots to a GUI. There may be more details yet to be found in journalctl.

last upgrade solve the issue 6.2.11 works now