Cannot boot with kernel above 6.2.15

Any kernel above 6.2.15 does not boot for some reason.
(Tried with 6.3.6, 6.3.8. Maybe some other too. I do not remember all of them.)

It seems to just gets stuck. Even without the quiet option it is not displaying anything useful.
I have an nvidia GPU with proprietary drivers installed.

Also this is not the workstation edition. It is a server with hyprland. Do not think it should matter with this issue though.

fpaste on latest working kernel(6.2.15) -

I also tried to get the logs from it, but sudo journalctl -r --boot=-1 does not have it. Either I am doing something wrong or a record for it somehow is not made?
I tried with different indexes too, but I only get entries for the kernel that is working.
(Jun 21 03:26:57 fedora kernel: Linux version 6.2.15-300.fc38.x86_64)

Any clue on what to do or do I need to stay on this kernel forever?

I already tried asking on the subreddit, but it did not really lead to anything.

Hi @rellablassa .

All I can really think of here is that the akmods weren’t run properly so the nvidia driver isn’t loading. Would you be able to boot into a non graphical boot and re-install them to see if that helps?

To do this, at grub, please press “e” to be able to edit the grub command line, and at the end of the line that starts with linux.., add, which should be the non graphical run level. There, you should be able to use dnf etc. I’d remove any kmod packages, and then reinstall the akmod-nvidia package to regenerate them:

sudo dnf remove kmod\*
sudo dnf install akmod-nvidia

Do note that even after the dnf command is complete, it may take a few minutes for the kmods to be compiled and installed.

One can check if the akmods are built and force them to be rebuilt using

sudo akmods --force

edited: tweaked dnf remove command

This does not seem like a good idea? Are you sure about this step?

Doing either this or adding btrfs flag to the newest kernel entry fixed it. (rootflags=subvol=snapshots/53/snapshot")

Also I skipped the step with sudo dnf remove \*kmod\*.

Probably a typo. I suspect it should have been sudo dnf remove kmod\* since that removes only the actual modules. Also may have required sudo dnf reinstall akmod-nvidia

1 Like

do you mean forcing the akmods?

Yeah Running akmod-nvidia install and forcing akmods.

1 Like