Fedora 35 live USB not booting

I downloaded from the website, but wrote into USB via rufus, because Fedora Media Writer is simply refusing to complete the process (it hangs forever at “checking written data”)

In case the uploaded image is trash, here’s the Google drive link:

Thank you for your help :slight_smile:

Hardware: Acer Aspire 7 laptop, Ryzen 7 5500U, GTX 1650

Please try the F34 iso ! It looks like that the kernel, used now F35, has a problem with the nouveau (opensource driver for NVIDIA)

Are you using windows or mac version of Mediawriter?

I tried Fedora 34 as well(had an iso lying around from a couple weeks ago), same problem :frowning_face:

I thought it might be the hardware, but 5500U isn’t exactly bleeding edge, and 1650 is years old now

I’m very sad my new laptop will not be running Fedora ;(

Windows version of FMW

Don’t bee ! For almost every problem exists a solution.
Did you try an alternative boot method while starting the live iso ?!

Lower resolution or so.

1 Like

If media writer is taking that long to check the iso maybe it’s a bad download.Have you tried the

This would mean, that his F34 he tried, also is defect. The errors on his screenshot shows nouveau problem … so must be something with the NVIDIA.

1 Like

I think the new laptop doesn’t support boot via BIOS, because I’m not getting that option in my laptop (but I remember getting it for F34 in my desktop)

And the F34 image is good, it got installed in my desktop, so bad iso download is not possible

I was refering to the Fedora 35 ios and I guess I missed the part about the new laptop.Is secure and fast boot disabled in the bios on the new laptop.

Yes, both are disabled

When the boot starts for the ISO, do you have the option to get to the troubleshoot command line instead of proceeding to install? If not can you get the BIOS boot menu up first and make sure it is picking the correct partition of the iso?

1 Like

Yes I get the option called “Troubleshooting -->”

It has only 1 option: start Fedora 35 in basic graphics mode

And it successfully booted!!!

I tried installing F35 from that basic graphics troubleshooting boot

It worked!!!

But the slick animations have gone :frowning_face:

Hopefully someone solves whatever issues are there in this live image

But a stopgap is to select the troubleshooting option from the boot menu(where it asks you to boot directly, or verify, or troubleshoot), and install it that way

There is normally a delay between the release of Fedora, and the Nvidia update. I think this is currently the case. Another thing about slick graphics of the installer, I think the UI enhancements have been disabled now, and you need to intentionally enable it. So after boot did you have better graphics than basic?

No :frowning_face:

I’m stuck without the smooth animations after the install as well ; _ ;

Will i be forced to use GNOME tweaks?


The brightness slider also isn’t working in this install.

Wow, this release is really all over the place, didn’t encounter this kinda stuff back in F30, when I first installed the latest and greatest the very day it released.

I again wonder if it’s due to my Ryzen 5500U, while it’s not exactly bleeding edge, it’s also been less than a year since it’s release, I think.

I think you’re asking whether I got higher resolution graphics after I installed it on disk?

No, but the so-called basic graphics mode only contained a loss of smooth animations; I atleast couldn’t tell any difference between the basic graphics and the normal versions.

@ilikelinux @jakfrost @straycat UPDATE

Just for the heck of it, I decided to try booting the F35 live image in my Desktop machine(Intel i5 4th gen, GTX 950).

The normal version booted up without any issues, it had smooth animations enabled by default as well.

After installing, there are no issues during boot either(and obviously there’s no brightness slider, but the OEM provided display setting works flawlessly)

As I imagined, it’s a hardware issue 100%

I’m extremely disappointed that Ubuntu 21.04 worked flawlessly while F35 fails to even boot the live USB without going through extra steps, and even after that, things like brightness don’t work properly :frowning_face:

Something to keep in mind regarding your CPU. Since I have a Ryzen 5600G Mfg’d this year I think, and I have been an almost exclusive AMD user for years, I have always been keenly aware of the lack of AMD support aside from generalized for some time. I understand that the new kernel coming for F36, so in Rawhide now, is 5.15, which has apparently a considerable update for AMD hardware. As in AMD actually has linux kernel dev’s being paid to do this.
Full disclosure here, I do acknowledge that the mediocre support AMD has given Linux in general is to thank for this situation. While Intel was making Clear Linux to better integrate their hardware in Linux, AMD was largely ignoring their Linux user base. I believe their new server offerings have played a role in their recent contributions.
In any case, it appears future kernel versions will be able to exploit AMD CPU’s better.

Ubuntu does not comply to the same level of licensing standards Fedora has set for itself. To compare them based on proprietary driver availability is a bit naive at best. Although I would still like to see a better user experience for the LiveUSB, but that is irrespective of whatever Unbuntu does.

Yeah, I didn’t even see the option to use proprietary s/w when installing F35, but did so for Ubuntu.

Sorry if my tone sounded accusatory, I didn’t intend that :frowning_face:

Hopefully the issues get resolved in the next few months and I can come back home :grinning_face_with_smiling_eyes:

Btw should I mark the post in which I wrote how selecting the troubleshooting and then boot with basic graphics option as the solution?

This is my first time posting in here, so not sure what the best course of action is.