Cannot boot fedora from usb (UEFI)

Good day, everyone.

I am new to the Linux world. I wanted to install Fedora on my old laptop, which has Windows 10 currently.

I wanted to try it out first to see how it felt, so a couple of weeks ago I created a new partition and set up dual boot, installing from a USB key I prepared with Fedora Media Writer.
Everything went smoothly, and I really like how nice and simple Fedora feels, so I decided to install it for good, overriding Windows completely.
I backed up the files I wanted to save and removed the temporary Fedora partition. However, yesterday, when I tried to boot from USB again as I did the first time, it started giving me the error in the picture, and it just won’t boot now:

error-photo

I already tried everything I could find: disabled secure boot, removed grub (which was installed when I set up the dual boot) from the efi partition, disabled tpm, and tried with a fresh image.

Nothing works. It keeps giving me that error and then goes to the command console for Grub, where I can only choose to exit or reboot and go into Windows.

The only thing I did with Fedora that could have caused issues was installing updates with

sudo dnf upgrade

because I wanted to try it out. Nothing else comes to mind.

All help is greatly appreciated.

Thanks a lot for your time!

Added anaconda, grub, installation, tpm

Some more infos please.

So you created a Fedora install stick a while ago, thats why it is still on 39. 40 is out but 39 is still supported well.

You then installed it and in there you updated the system? That doesnt matter really.

You then removed the partition again, how? Inside Windows?

Did you ever successfully boot into the install OS after installing Fedora. Or did you update the install media? That shouldnt do anything as far as I know.

So a few basic things to try:

  • if you still have the ISO, use Fedora media writer or Rufus on Windows and recreate the install stick
  • try to use Fedora 40 and see if that works

I cant help with the TPM errors, and more info about your laptop / PC motherboard, BIOS name, etc. would be helpful.

Thank you first of all.

Yes I created a fedora install with fedora 39 before 40 released. I didn’t update to fedora 40 however. I saw the option but I decided I would update it later once I did the full installation.

I removed the partition I set up for Fedora from Windows, and reclaimed the space I had set aside, again to prepare for a full installation.

While I had dual boot I could use both Windows and Fedora with no problem. Now i can only use windows, since I removed Fedora, but i can no longer boot from the usb, and it gives me that error.

I will try to use Rufus instead of media writer and see how it goes.

As for the PC it’s an ASUS X555LJ. The UEFI BIOS is X555LJ.602.

Thanks a lot for your time.

1 Like

Perhaps the UEFI non-volatile storage has run out of space, for example too many entries in the boot list as shown by efibootmgr. Also updating the dbx could exhaust the available space.

2 Likes

This is a common problem across multiple distros and is with the vendors UEFI “BIOS”. Solutions usually start with disabling secure boot. In some cases it was solved with a UEFI (“BIOS”) update from the vendor. There are vendor-specific workarounds using the vendor’s “BIOS” settings for “Add boot option” to select EFI\fedora\grubx64.efi.

ASUS forums may be able to give more specific advice.

1 Like

This means you need to skip the “bootloader installed” verification, as the OS will not install otherwise, right?

How would this be done?

Since this issue is with vendors UEFI (“BIOS”) the fixes are specific to each vendor. If the vendor doesn’t have updates or specific help, people try random stuff that worked with other vendors.

1 Like

Good day everyone.

These couple of days I tried the solutions you all suggested:

  • I tried making the installation usb with Rufus.
  • I tried the same with the fedora 40 image.
  • I tried “Add boot option” in the BIOS settings to select EFI\boot\grubx64.efi, and put it as the first choice in the booting list.
  • And I also updated the bios to version .604 (I had no idea it was available before).
Nothing changed unfortunately. I keep getting the same error or slight variations of it. I want to also point out that I disabled both secure boot and tpm.

The only thing I am not sure how to do is the solution @vekruse proposed.

Perhaps the UEFI non-volatile storage has run out of space, for example too many entries in the boot list as shown by efibootmgr . Also updating the dbx could exhaust the available space.

As I understand it this is something I would have to do from within Fedora right? However I do not have access to it, I can only use Windows.

I will also try with a different distro and see how it goes.

Thank you again, I really appreciate your help.