Install Fedora in external HDD without touching internal HDD

Dear Friends,

I have a loaner laptop which has Windows 10, but I want to run a full installation of fedora without touching the internal HDD.

So I bought a USB HDD and installed Fedora 30 Workstation to it. It all looked like it went well, but when I choose the external HDD as boot device, it fails to boot. (It just pauses for two seconds and comes back to the boot device selection menu.

Did I do anything wrong? Doesn’t it usually work this way?

Help please.


It doesn’t sound like you did anything wrong. Do you have the steps you took within Anaconda during the install? Does the external device have it’s own MBR?

Also, does the machine use UEFI? This could cause problems with booting to USB-connected devices.

G’Day Striker.

I am not sure if it has any such MBR Partition. This is the pic of what I see when I open in Gnome Disks.

But I remember chosing a boot partition.

IIRC, I went with the default options, but I changed the size of the partition. It must have had these options as in this screenshot :

This is what it shows in gnomeo-disks when I view the external hard drive :

The machine does have UEFI, but I have set the legacy boot as default option. I even tried booting the machine without UEFI, but no luck. (The machine is TP L470)