The Drive that contained Fedora install is Missing from Boot Menu (Newbie)


So Here’s the background for the issue.

I installed Nobara 36 (a modified Fedora 36 GNOME edition) and it was working fine on the external HDD until someone disconnected it whilst the computer was shut off and now i cannot find my Fedora installed drive in the boot menu. Also When it was working there were two drives to boot into in the boot menu

Why the two though i didn’t install two of them but just giving information of how the install was done from here on out.

First I Format 1.4 TB of space off of my External HDD that contained Ubuntu 22. Then Extended My NTFS Disk on that ext drive from 388 GB to 1 TB ( I use that as a backup for windows files )
Then the rest of 800 GB on that drive was unallocated and i extracted the iso file onto a 16 GB USB and just booted into that USB drive. After Start I selected install to Drive and then when selecting the location I chose the External hard Drive and used the custom partition so that it wont just format the entire drive. made a 1 GiB EFI Partition (\boot\efi), a 16 GiB Swap partition (I heard it was a good practice to get the same amount as your Actual RAM which is 16 GB DDR4), The Root partition with 100 GiB () and The Home partition with 600 GiB (\home) .

The install went perfectly no issues other than WiFi not being recognized which wasn’t an issue with Ubuntu but that’s fine I connected Ethernet and Just did the usual software installs.

I also Restarted the machine a multiple times and jumped from the internal drive to the external drive in the boot menu and all was going well and no errors occurred. other than the fact i Had two options in my boot menu:

Windows Boot Manager
Data Storage Device

I always chose Nobara though thinking it may mess up.

Well while it was installing a steam game, it was 3 AM so I went to bed. Later that day I come to the Computer and find out that the ext HDD was disconnected and the computer was shut off so? I connect it to the back and get into the boot menu but… What? Where are the two options? Nobara or Fedora? both were missing. So i though maybe just maybe my ext hard drive failed via a force shut down of the computer or someone pulled the external HDD out while Fedora was Active.

I boot into Windows boot manager and Search ‘Disk Management’ and lo and behold The disk was fine! also the NTFS Partition was working fine too. So what happened then? Also I installed the official drivers for the external HDD by WD and still no change.

here’s what Disk management showed

Here are my specs.

Motherboard : ASRock B450 Steel Legend
CPU : Ryzen 5 3400g ( AMD Vega 11 Graphics )
RAM : 16 (8 x 2) GB RAM DDR4
2 Internal HDDs (1 TB + 500 GB)
1 External HDD (2 TB)
ALFA 802.11n long range WiFi Adapter
no Bluetooth.

Also All the Drives are in GPT/UEFI

I am also just a Highschool Student who doesn’t understand most of linux and just had recently switched as i relaised that linux’s Visual Studio performs 7x better than the Windows counterpart. So please regard me as a Newbie to GRUB, EFI/UEFI, Kernel and other technicalities. and yeah WIndows 10 Pro 64 bit

It seems that what happened was that someone disconnected your external drive then may have booted the system without that drive connected. Since you have 2 drives with efi partitions (windows and the external drive) (shown as disk 1 & disk 2) the system booted to windows and the windows boot loader overwrote the boot sequence for the external drive in the bios.

You probably can use the bios boot menu to select the external drive for booting.

Once booted to linux we can look at the efibootmgr output to see what it says for boot sequence, etc.

I would have installed to the external drive, but allowed fedora to use the efi partition on the internal drive for its /boot/efi data and thus all would have been good even after disconnecting and reconnecting the drive.

If you are up to doing a reinstall then the easiest way would be to delete the 3 partitions you created on disk 2 (efi, /home, and OS) while leaving the swap.
Then do a reinstall, selecting both the windows drive (disk 1) and the free space on disk 2 as the target and do a reinstall. You could then, do an automatic install which should select the efi partition on disk 1 to mount as /boot/efi, create an ~1GB partition on disk2 as /boot, and use the remaining free space as btrfs for / & /home. The installer is smart enough to use only the free space and not overwrite anything else.

Once the install is completed then fedora’s grub will have control of booting and allow you to select fedora on the external drive or windows on the internal drive to boot. Of course, if the external drive is disconnected it cannot boot there, but still could boot windows.

See the issue is that even in the bios boot sequence I could not find my external hard drive. And regarding reinstalling. Well I will try it in a few minutes.

Uh about that… It seems after I installed the official driver for the external hard drive. it has reappeared in the boot menu once again.

So now that it’s back… Is there anything i can do to prevent such an occurrence to happen again?
Can’t be sure that someone won’t remove the drive again. like moving the grub (\boot\efi) from Disk 2 to Disk 1? I did that once on Ubuntu and it was quite simple. Or before that Should I test the situation once again?

Yes, it is possible to move the files from disk 2 to disk 1, change the boot info on fedora so it knows the efi partition has been relocated, and work with that.

It is possible, but much simpler to do the reinstall. As an experienced Linux user I could do that. I would not expect a relative newbie to do so without a lot of frustration and guidance.

If you wish to try it (no guarantees of success at first try) you could simply copy the directory and contents of /boot/efi/EFI/fedora and /boot/efi/EFI/Boot to the similar location on the efi partition on disk 1. You would then need to unmount the existing /boot/efi, edit /etc/fstab to mount the other efi partition there, mount the other partition, then run sudo grub2-mkconfig -o /boot/grub2/grub.cfg and probably sudo dracut --force to make certain all the images are up to date before rebooting.

Finally you would want to remove the efi partition on disk2 so it does not interfere in any way in the future.

So … The same situation occurred again. One of my younger siblings unplugged the drive bcoz he didn’t know how to boot into Windows. And well this time it’s fine! The boot menu didn’t erase my external drive. Nor was it showing any signs of previous issues. So i guess it’s fixed?
Like all I needed to do was update the external drive in the device manager of windows 10 where the external drive was in the others section with an /!\ mark on it with the official drive software that came with the package.

This should not be needed. Updates like that needing to be repeated show an error in the bios.

If you do the switch of the efi as noted before it is very easy (even standard) to have the grub menu show windows as an option and then it is easy to teach others how to select which OS to boot.

This seems an ideal situation where you can encourage your siblings to experiment and learn to use linux as well. Simply set up an account on fedora for them so they can learn and play! :innocent:
As long as you do not give them sudo (administrator) access they cannot break your system. :grinning:

Thanks for the suggestions but I don’t think my siblings have any interest in other OS’s except windows.

[People who are here for a solution just turn back or skip the next 6 paras which are just sibling issues]

They’re like > BRO why da duck do you install other OS on our computer? just use windows and I say > I have my reasons.

One of them being the fact that they have zero interest towards Linux so they won’t be messing with my files and all which are usually are in the trash in windows

They very often mistake my python files as some virus bcoz I create some bots to automate my work. And when they by mistake run those files.

The bot is like :
wait one second, Press F2, press home, press delete three times, press enter, press down-arrow-key and then loop this process a definite number of times.

And in wrong occasions that sequence of buttons can start wrecking havoc. And then they be like alt f4 and then delete my .py file.

And about giving them other users I’ll rather not as it won’t do much difference. They just don’t care about anything except windows.