Windows 11 upgrade removed my boot menu


I was happily booting to the Fedora 38 boot menu and selecting either Windows or Fedora, but then , i upgraded windows 10 to 11. And, of course, it now boot straight to windows with no choice of Fedora. My Fedora is on a separate SSD on the PC.

Can someone please help with steps to remedy the situation? I hope there is a simple step or two to get into Fedora and remedy the situation.



Is there a boot entry for fedora in the uefi settings? You could switch it as the default boot.

This is the reason why i barely ever boot up my windows install and am even thinking of getting rid of it.

You could also run windows in a vm and not worry about the two operating systems murdering each other.

In my case Windows is the default boot with occasional forays into Fedora. The PC is shared.

There will be a entry for the disk in the bios, but I’m guessing Fedora set up a boot record on the primary ssd which Windows has trampled over. Possibly the best solution is to install a boot record on the fedora drive itself, and boot that drive from bios?

Hello @dale77 ,
There should still be a boot entry for Fedora if there was initially enough room. I have had success in this regard in the past. Having more than one efi partition available is not going to work well with Grub (Fedora’s bootloader). You could use the live image media of Fedora to boot the system with and have a look at the efi partition size to see if it is adequate in size, you could also do this in Windows. You may be able to perform a system rescue with your original :fedora: installation media too.

Thanks Stephen. I guess what i’m after is the golden instructions for how to get my boot menu back. The setup used to be:

Win10 on primary ssd, Fedora 38 on secondary ssd, grub installed with boot menu pointing to Fedora and windows, with windows default. uefi bios booting to primary ssd.

And is now:

Win11 on primary ssd, Fedora 38 still on secondary ssd, grub nowhere to be seen and no menu presented. Win11 boots. Smirking.

What does the boot menu from your Bios offer? I get mine with [F12] on my ASUS system and [F8] on my Lenovo and Dell systems. At boot time I have to press the [FKey] to get the menu or go into Bios and select form there.

As for the easiest in my opinion is to use the Fedora installation media to rescue an already installed system. It should be able to re-write your Grub menu without anything more than you selecting the option at the first of the install run (ie… when you pick install, test media and install, or rescue system).

I went into the bios and there were a fiesta of options to boot from, including a couple for Fedora ones on the second ssd. Selecting that as the boot override got me back to the grub menu.

So, I am now back to having my boot menu, as i simply moved the fedora boot option to #1 and windows to #2.

Thanks, looks like what Windows did was make itself top priority in the boot order.


Yes, it tends to do that. Glad you got it back working. Cloud you please mark the solution you came up with as someone else very well could run into this same issue?