Can not boot into Fedora after dual boot installation

Hi to all,
I’m encountering some issues in a dual boot installation, Fedora and windows 11.
I installed fedora several times and did the usual steps.

  1. Reduce the windows partition with windows disk utility.
  2. Create a media installation with fedora media writer
  3. Boot from the media disabling secure boot.
  4. Allow automatic disk partitioning from anaconda

The installation seems to end without any error. After rebooting I can’t see Grub2 menu at all and it boots directly in windows.
I tried both F37 and F38 beta with the same result.
I’m trying to install to a Thinkpad p53s i7.
Any advice would be appreciated.
Many thanks in advance.

I think it is worth checking in the bios what it knows how to boot.
You should see a windows entry and a fedora entry.
Try making the fedora entry the default.
Does that get you to grub?
Hopefully grub menu has a windows entry as well as the fedora ones.

1 Like

It seems that grub2 is not installed. I can’t see any other os than windows. I think i had to fix this througth a live image of fedora.

Hi, I re-installed grub from live image, following the very accurate step-by-step fedora docs. It seems to end the installation fine.
Here the content of the efi partition.

But I still can’t get grub starting on boot. Which bios setting have I to look for? In boot option I excluded Windows Boot Manager at all, but It starts anyway.

Check bios boot priority option.There should be windows and fedora set just windows is on first place change it that fedora is on first place

This is example with windows just installed .You should see fedora too. Just move fedora to first place to boot fedora

I got it. I found a specific guide by Lenovo to install Ubuntu on a Thinkpad p43s/p53s.
You have to disable a couple of Windows’ optimizations in UEFI menu before starting the installation. Once done that, everything goes fine.
Here the link to the guide!

Thank for your suggestions.