Cant boot into fedora


few days ago i tried installing Fedora-38 as dual boot with my Windows 10 on my Lenovo M91p Desktop (ThinkCentre) - Type 4518. Everything went ok, i followed some YT tutorial, created partition, installed Fedora and finally restared my PC to test it out. Unfortunately, my PC didnt offer me any bios menu, where i could choose, whether i want to boot windows or linux, it went straigth into windows. After lot of googling and trying to fix things myself, I managed to get into some kind of “menu” but it had only windows as an option. My bios is from 2011 and it doesnt even have a boot tab, there is no secure boot option and certainly no boot order. I tried to update my bios, but I found out that it most probably isnt possible (Lenovo app said there are no updates). I spent some time in a terminal via the instalation USB and there i tried to reinstall grub, unsuccessfully mount the efi partition to my system (i didnt know what i was doing or what i was supposed to achive and it certainly did not work). I can confirm, that the Linux should be installed in desired partition as i could see it via Gparted. I am quite unexperienced and therefore dont even know how to proceed or how to sort things out. I would appreciate any help,


The youtube tutorial may not have been accurate for your system.
The fedora installer when booted from the usb is normally able to handle a clean install with minimal user interaction especially if using the automatic partitioning option.

It helps to ask the experts here before blindly following some unknown user on youtube.

Please boot the system using the live USB you must have used for the install then open a terminal window and post here the output of lsblk -f so we may see the drive arrangement and file systems.

Also, show the output of efibootmgr. You can do that while running the live system you used to install Fedora in the first place.

From that output it would seem that if you were to use

  1. su
    to gain root permissions

  2. efibootmgr -n 0002
    to set the system to boot fedora with the next boot
    Then reboot it should boot fedora.

Note that the boot order does not put fedora before windows as it is. In fact network boot is before any of the installed OSes, as is the ‘hard drive’ ? listed as Boot0000, and that device appears to be what was last used to boot.

One can reset the boot order with efibootmgr as well. Possibly one would want to use
efibootmgr -o 0002,0004,0005 to set the boot order with fedora first (both entries) then windows (efi) last.
Boot0002 and Boot0004 seem to be exactly the same.

Thansk for the tips, I tried probably everything, but unfortunately didnt get into fedora once. In BIOS i set boot mode to UEFI instead of auto so i would avoid legacy, I tried setting up fedora as next boot aswell as manualy seting boot order. Nothing works and i always go straight to windows. Boot order somehow resets itself. I have i5-2400 and bios from 2011 so that might be part of the problem. Not really sure how to move on from here.

I see that you’re getting two pros helping you already, but I thought I’d sneak in a dumb question: When you look at your boot order in your BIOS itself, do you see the same order you’ve just set using efibootmgr?

Good luck!

I don’t know if it is an option to just get another computer of the same type. They seems to be available on Amazon, and depending on where you live it can be quite affordable.

You can then ditch the windows completely on one of them and load Linux in non-uefi mode. It all depends on your needs and on how much you are able to spend.