Fedora 38 not booting

Fedora 38 is not booting. I have been using fedora for almost a year, recently I have reinstalled fedora38 after using for a week it stops booting. My windows OS was also currepted. Now I can’t even access boot menu. Sometimes it gets started but suddenly screen freezes after one or two minutes.

I am using Lenovo IdeaPad gaming GTX graphics card, rhyzen7.
I have also tried to boot with live OS with USB. But I can’t do anything the system freezed after sometime.
Someone please help me to fix it.

maybe a little technical detail like:

  1. is there any last error message displayed ?
  2. what last thing you do before the error occur ?
  3. maybe giving some photos ?

my assumption if your windows os also get corrupted that might be a hardware issue, fedora wont touch or make any dangerous changes without your consent (something that involved asking sudo or displaying huge warning message first).

or also it might be related to this ? Kernel 6.3.8 and later doesn't boot on my ThinkPad E14

1 Like

Firstly thanks for responding.

My screens keeps freezing during last week’s. But it got right after restart with power button. After Sunday, screen wakes up and starts but screen freezes after one or two minutes.

From Monday, screen wakes up and os failes to start with circle rotation with fedora logo.
Yesterday I got following error on pressing esc on journalctl(command similar to that)

Currently it is not waking up. Power button, charging is blinking. Caps lock and num lock are not working.

Windows is currepted after I used gparted to resize the partitioning.

out of my reach unfortunately, maybe a more senior here can give a better resolution later, just be patient until they see your post okay.

in the meantime, is your bios or uefi fine ? you can make some small changes here to prioritize booting from usb (there many tutorial in internet for that).

do you have another spare workstation ? try to create another or different live usb os to use.

thats all i can tell for now mate, hope you can resolve your problem.

My bios is not opening. Even it opens once or twice in a day the I don’t get enough time to change partitioning as screen get freezed in meantime. I have also tried to install new OS but same problem there too.

I would again thank you for your support.

sound like failing hardware.
can you run a memory check?

Maybe, but I am having trouble in loading the os. Even my bios is not loading. Is there any way to check memory in such conditions.

1 Like

If one cannot open the bios then it seems it may be hardware related.
In most cases the bios should be accessible even without a functioning OS.

One may usually open the machine and remove and reseat the RAM chips. While out the contacts may be cleaned by using an eraser on the contacts of the DIMM and possibly using air to blow out any potential dust from the socket.

If one were to download and create a bootable memtest86+ usb device then booting to that device would allow testing the memory. If this is not possible then it may be a deeper issue in the hardware.

What if this is heat related? That can happen should

  1. Air passages become blocked causing overheating
  2. Fans fail causing no air flow and overheating.

In this situation the overheating may occur sporadically in time but certainly very quickly especially during boot.

This also would require opening the case for inspection and cleaning.

1 Like

Finally able to fix after five days. The problem actually was in the RAM. Now the system is working fine on removing defected RAM.

Thankyou everyone for support.