Installing Fedora deleted all my BIOS and boot menu setup

HELP: I just installed Fedora, but I am a Debian guy. I tried to open boot menu with f1 in my “Lenovo Ideapad Slim 3”, now the f1 boot loader isn’t working (any other bootloader buttons as well). And LENOVO logo gets stuck when F1 or any fKey is pressed. I tried a custom boot loader and opened UEFI firmwork bios, changed the boot priority to both Fedora and Ubuntu USB (which is working on my desktop) or Fedora but that did nothing. I tried this several times. What should I do?

You shouldn’t need to use the bios boot menu, just try booting without that first, then let us know the results. I have no experience with lenovo, but I use fedora a lot and have had no issues with it on any machine I use it on. If you installed fedora after Ubuntu, try holding the shift key down while booting and it should bring up the grub boot menu.

I also need to ask if Ubuntu was installed in legacy mode and fedora in uefi mode or vice versa? Installing them in different modes causes problems.