After install no boot


Over the weekend i was trying to install Fedora on my Lenovo x220.

At first the live dvd did not boot. With the KDE flavour it worked and I installed Fedora on my Laptop (workstation with KDE).

Everything went like a breeze, but after booting I was promoted with the selection of my drives for boot selection.

Is there anything i can do, beides selecting the correct drive to boot from?

Thanks for the help.

Kind regards

Does your drive have more than one OS, e.g., are you dual booting with Windows (which version?) or is Fedora the only OS installed on the drive.

Are you using UEFI or BIOS boot management?

After installing from the Live ISO, you should boot to the newly installed Fedora and continue with configuring a user, etc.

Fedora Step-by-Step Installation has screenshots. Details may differ between the Gnome and KDE, but did you reach “6. Post-installation – Basic Fedora 38 Activities”?

If you still don’t get to the Fedora configuration step, a picture of the screen with the selection of the drives may be helpful.


no, no other os ist installed. The ssd was erased completely. I even freshly installed fedora 38 with KDE. The message in the installer said “all good”.

To be honest, I do not really know, if UEFI or BIOS is used. Since the x220 is a bit older, it might only be BIOS.

The step 6 I did not do, but during install I created the user and the password. But is post install not within the freshly booted Fedora? This I can’t start.

This image is from the booted live dvd.

Before Fedora there was Oracle Linux 9 installed. Which booted without any problems.
A video about the boot process: Fedora boot fail on Vimeo

During the boot one may select to enter the bios setup menu and usually there is an option to select {CSM or Legacy} which usually allows one to select to boot legacy mode or uefi at boot time, or {UEFI only} which forces the system to boot in uefi mode only.

If the system allows mode selection during boot then, for devices that are optional mode booting such as the fedora live images, one may usually select from the boot menu to use legacy boot or uefi boot on the same usb device.

Usually the mode one chooses to boot the install image is the one used to boot the installed OS. I see the usb device, one just the plain device and one overlaid with ‘uefi’ which tells the mode used for boot.

When installing workstation one does not create a user during the install, but that is done during the setup as part of the first boot process after the install completes.

Also during the install one has an option to erase the entire disk and install to it, so the removal of the old OS and the install is done as a single process. Is that what was done? or did you use some other process to wipe out the original windows install? If not done in this manner it is quite possible some artifact from the old OS may remain and interfere with proper booting of the new fedora install.


maybe it’s an import information. Booting from USB was not possible. The USB Stick was not visible in the boot option. The Installation was done with a DVD.

I looked up the legacy boot thingy. The setting is set to legacy.
Since I tried multiple times, I erased the disk with KDE Partition App and used the installer option to erase everything. The result was the same. Not booting into Fedora.

Ubuntu, Oracle Linux and Manjaro was not a problem. Maybe the Lenovo X220 is too old?

Quick update: I created another boot usb stick (usb2, not usb3) and checked (again) the bios and set it to legacy and activated boot diagnostics.

For now it works.

1 Like

Glad it worked. Early USB3 support is not robust. You are definitely pushing old hardware about as far as it can go.

Definitely not too old. If the desktop is laggy you may want to consider XFCE or LXDE. A lot depends on what you want to do with the machine and how much RAM you have. I run a x201 with XFCE just fine (8GB).

1 Like