Dual Boot with Win10, switching from Ubuntu. WIndows is not booting


I’m new to Fedora (37), switching from Ubuntu.
I have a laptop (ThinkPad T430). Before the switch, I had a working dual boot with Ubuntu 22.04 and WIn10, with a customized GRUB Theme. Now Only Fedora is loading.
Linux Is my main system, I only use Windows these days for my cutting machine.

I did a great job with backing up my data, preferences, gnomes settings etc from Ubuntu. But I’m afraid I messed up during the install process.
I installed Fedora in place of Ubuntu, on the same partition.
When I start the computer, I only see the GRUB screen for 1 or 2 seconds (with no option, it only says “GRUB loading, welcome to GRUB”) then Fedora is loading.

It’s been a week and I tried to read as much info as I could to solve my problem but I don’t really understand how it works.

I didn’t remember that my device was UEFI compatible to be honest.
I try to “boot from the BIOS”, choosing a temporary startup device. I see Ubuntu, Windows Boot Manager, the disc player, the hard drive, and the PCI card. Windows Boot Manager doesn’t work, nor “Ubuntu” (this one seems normal).

I tried what this user tried but it did not work :

It would be really cool if I’m able to repair the boot and not go through the install process again, as In the meantime, I pretty much set everything up on Fedora and I’m a bit discouraged to have to go through all of it again.

The output of $ lsblk and $ fdisk -l is down below, if it’s of any help.
$ os-prober results in no output (concerning… :confused:)

Thank you!

$ lsblk

sda      8:0    0 232,9G  0 disk 
├─sda1   8:1    0   260M  0 part 
├─sda2   8:2    0    16M  0 part 
├─sda3   8:3    0  80,6G  0 part 
├─sda4   8:4    0  1000M  0 part 
├─sda5   8:5    0     1M  0 part 
├─sda6   8:6    0     1G  0 part /boot
└─sda7   8:7    0   150G  0 part /home
sr0     11:0    1  1024M  0 rom  
zram0  252:0    0   6,4G  0 disk [SWAP]

$ sudo fdisk -l
Disque /dev/sda : 232,89 GiB, 250059350016 octets, 488397168 secteurs
Modèle de disque : CT250MX500SSD1  
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : B6BE48D9-4FDD-4FD1-8FA3-E31D90CFC53B

Périphérique     Début       Fin  Secteurs Taille Type
/dev/sda1         2048    534527    532480   260M Système EFI
/dev/sda2       534528    567295     32768    16M Réservé Microsoft
/dev/sda3       567296 169678847 169111552  80,6G Données de base Microsoft
/dev/sda4    486348800 488396799   2048000  1000M Environnement de récupération Windows
/dev/sda5    169678848 169680895      2048     1M Amorçage BIOS
/dev/sda6    169680896 171778047   2097152     1G Système de fichiers Linux
/dev/sda7    171778048 486348799 314570752   150G Système de fichiers Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.

Disque /dev/zram0 : 6,43 GiB, 6909067264 octets, 1686784 secteurs
Unités : secteur de 1 × 4096 = 4096 octets
Taille de secteur (logique / physique) : 4096 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets

That looks like you had windows installed as efi and you installed fedora in legacy mode.
With fedora doing a bios boot it will be impossible for grub to also boot windows in uefi mode.

I suggest that you boot to the live media you used to install. Make sure that you select uefi as the boot mode, or enter bios and set the bios to boot uefi only before booting the fedora media.
Once booted into the live media in uefi mode then use fdisk, gdisk, gparted, or your other favorite partitioning tool to remove partitions sda5, sda6, & sda7.
Once that is done then do a clean new install of fedora into the free space and allow it to do the automatic partitioning.

During this install fedora should now find windows and be able to set up grub for dual booting.


Thank you!
Alas, I will have to install again :slightly_frowning_face:
I’ll report back when I have the time to do it!

I’m trying to understand why the dual boot worked previously with Ubuntu. Do you think it’s probable Ubuntu was installed in UEFI mode too but it was managed in GRUB? It’s been years since I first installed Ubuntu on this device (which I think was 18.04 at the time), and I can’t remember.