Tried installing Fedora dual boot. Now can't boot windows. Help?

I tried to install Fedora 32 alongside my installed windows 10 and now I can’t boot into windows. When I boot it goes straight into Fedora and if I go to bios and select what I think is Windows it tells me this drive is not bootable etc. Inside Fedora I can see the win partition and access and use all the files on it still though. I think it might be because windows is booting using bios and fedora booting using uefi? Is there anyway I can be able to boot back into windows or dual boot or anything?

When I started i had a windows c drive partition with win 10 on it, a small recovery partition, a four mb of unallocated free space and and 94 gb of unallocated free space. I tried to make a / and a /swap on the unallocated space but it gave me errors telling me

“Failed to find a suitable stage1 device: EFI system partition cannot be of the type ntfs. Efi system partition must be mounted on one of /boot/efi; EFI system partition cannot be of type ntfs; EFI system partition must be mounted on one of /boot/efi; EFI system partition cannot be of type ext4; EFI system partition must be mounted on one of /boot/efi; EFI system Partition cannot be of type swap.”

I instead selected the manual configuration non gui and told it to set up BTRFS partitioning automatically for me. It installed but now I can’t boot into windows.

I’m pretty new to linux so let me know if you need any more info or me to run any commands. Thanks for help!

Hey @linuxx420

Welcome to the Fedora Community.
I’m sorry about your experience. First confirm that your Windows partition is intact. Boot a live media and take a peek. If all is there, there’s nothing to worry about. You need to reinstall Fedora but, this time, make sure you mount your EFI partition at /boot/efi. You can make sure of it by using the custom partitioning or Blivet.

DO NOT FORMAT THE EFI PARTITION … only mount it at /boot/efi

Other partitions you will need:

/ – mandatory (root)
/home (recommended)
/boot – mandatory
/swap – mandatory
/boot/efi – mandatory (but it already exists. Your Windows OS uses it too. It is the EFI system partition that came with your machine. DO NOT FORMAT IT. Just mount it at /boot/efi)

I can see and access windows and it’s files when I boot into fedora or use fedora usb. I tried to get help on another forum and they said they think my problem is that I installed Fedora in UEFI mode but my windows that was already installed was in legacy/BIOS mode. They said they think I need to reinstall Fedora in BIOS or legacy mode. When I checked partitions before installing Fedora there was no UEFI partition.

When I did the manual config and told it to auto setup partitions it created all of those partitions for me that you listed. It say’s I have a mounted /boot/efi now but it won’t let me boot to windows. Do you think I should still follow your advice? Just put in usb and delete all fedora partitions and reinstall? Or should I not be using UEFI? When i last used linux years ago there was only BIOS i think so im a little confused.

what is the output of the following command when you boot into Fedora:
sudo lsblk | fpaste

try these:

1.dnf install ntfs-progs -y

2.grub2-mkconfig -o /boot/grub2/grub.cfg


if you are efi system change number2 to:

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Here you go. The 836 GB is the windows 10 I believe. The small one under it is windows recovery it says.


  2. sda 8:0 0 931.5G 0 disk

  3. ├─sda1 8:1 0 836.5G 0 part

  4. ├─sda2 8:2 0 517M 0 part

  5. ├─sda3 8:3 0 600M 0 part /boot/efi

  6. ├─sda4 8:4 0 1K 0 part

  7. ├─sda5 8:5 0 1G 0 part /boot

  8. ├─sda6 8:6 0 7.9G 0 part [SWAP]

  9. └─sda7 8:7 0 85G 0 part /home

  10. sr0 11:0 1 1024M 0 rom

1 Like

You can’t mix the Bios/ boot modes. Stick to one!

1 Like

Yeah I didn’t realize I did that at the time. Is there a way to fix it now though? Should I run the commands @alirezarm suggested still?

How do install Fedora in BIOS instead of UEFI mode? I figured I can just delete the Fedora partitions and and reinstall Fedora in BIOS mode? Maybe that will fix it.

Just set your machine to boot with legacy/BIOS mode. While in the mode, boot a Fedora install media (DVD/USB). It will install in whatever mode it booted with. If you are installing in BIOS mode, you do not need to specify /boot/efi partition.


1 Like

The strange thing is in my BIOS I can’t find any way to switch it between legacy/uefi mode. If I do reinstall will it be able to boot to windows or did i delete some kind of boot partiton for windows that I need to now reinstall or something?

What’s the machine spec. E.g. Dell Inspiron XXXX … and any information to help identify your BIOS information?

dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 2.6 present.
101 structures occupying 3599 bytes.
Table at 0x000EAD50.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: American Megatrends Inc.
Version: 2103
Release Date: 11/30/2011
Address: 0xF0000
Runtime Size: 64 kB
ROM Size: 4 MB
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
BIOS Revision: 4.6

The name of the machine … usually, the name of the brand followed by numbers or a combination of numbers and letters

It’s custom built pc that was passed down to me with Asustek p8p67 Deluxe motherboard. Intel core i7 cpu and GeForce GTX 560 Ti video card.

Here’s a picture of my bios too if it helps any Imgur: The magic of the Internet

I’m familiar with this board. Looks like it is currently set to Advanced Mode. The display of the “boot” tab is of interest. The display of the BIOS screen in EZ Mode is of interest too (i.e the mode that shows hard disk to the bottom-left corner).