Tried dual booting, didn't go so well

Basically I’m somewhat stupid when it comes to troubleshooting on Linux. I love Linux and I want to make a full switch down the road, but for now I thought why not use Linux alongside Windows. I used Fedora a couple months ago, I enjoyed it but ended up switching to Windows because of the anti cheat issues on Linux. So I don’t think it’s a hardware issue anywhere because I had a perfectly well running version of Fedora running on the exact hardware.

I shrinked my SSD, made it so half of it was windows and another half was Fedora. I booted into my Fedora USB and ran into my first issue. It failed the check at 004.8%. I looked it up online and someone suggested to go into Troubleshooting and install the low graphics mode of Fedora. I thought it was gonna be low graphics only for the live USB until I installed it.

Anyway, now I’m in a fresh Fedora install, but I want to reinstall it so that I get the proper version of it. So I tried booting into Windows from the BIOS, not there, then I tried looking on the grub menu, also not there. I looked up the issue and found that updating the grub config would help… it didn’t.

I was worried and wondered maybe my windows got deleted or something, but it’s still there. So now I’m stuck trying to get back into windows with a unappealing version of Fedora.

I’m hoping someone would come and save the day. Thank you for taking the time to read.

Fixed the issue, it was because I didn’t boot from the UEFI USB partition when installing Fedora, so I reinstalled the ISO, flashed it to the USB and then reinstalled Fedora using the UEFI partition and now grub can detect windows and I can boot into it. :smile:

1 Like

It is strange that Windows isn’t listed in your BIOS. I think it should be there. It is hard to say what might have gone wrong. There are many possibilities.

The Windows installation disk might be able to repair your boot partition and/or BIOS settings.

Edit: It looks like we posted at the same time and my response was unnecessary. I’m glad you were able to figure it out. :slightly_smiling_face:

1 Like

What a coincidence :sweat_smile:. Thank you for trying to help! :blush:

1 Like

This type error seems always the case when fedora is installed in legacy/csm/mbr mode while windows is installed in uefi mode. Grub cannot see nor boot the uefi OS in that case.

It is always up to the user to verify the proper boot mode when installing dual boot.
To avoid such snafus I try to set the bios to boot uefi only, then it never will try to do an MBR boot installation. When CSM mode is selected in the bios it seems the default is usually legacy/MBR boot.

Added dual-boot, grub, windows

Glad you were able to solve your issue.

For future reference, when asking for help with Fedora, you should include (as text using the </> button) the output from running inxi -Fzxx in a terminal. This provides searchable text so others with similar issues/hardware can find your post.

1 Like