Grub issue and windows does not boot

I have mounted Fedora 35 ISO using Rufus to a USB and tried to install. I choose the USB to boot from and select to start Fedora. It gets to the wallpaper and the installation menu doesn’t appear, I can still click the settings menus with right click. I have tried 35 and 36, ISO and Media writer, also different USBs. The ISO worked when I used it on virtualbox. So I am not sure what the problem is? Is it my PC?

I am running a i5-6600k and 1060gtx

Welcome to ask.:fedora:edora @vengefulsquid

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

It won’t let me open the terminal or any apps

Can you verify your iso with sha checksum if it is alright
In first go to the folder containing iso linux sha256sum filename.iso
In windows it is
Certutil -hashfile filename.iso sha256

It is an official iso

I think it might be my pc hardware causing the issue?

Yes but while downloading some time it can be broken it mostly never happens but be sure about it .do it and compare.

Could be but there are millions of users using and maybe 1000s with your processor so might me something else.

okay. This is what I got for checksum. That’s for 35


I apologise, I am little new to this.

1 Like

When looking at some forums some people say Nvidia drivers or M.2 drives do something similar, but I can’t find anyone who has the same problem as me.

I just tried Ubuntu and that gets the install prompt up.

I am not sure I understand what you are saying.
For me, when I boot from the USB the very first screen that shows up has 2 icons (rather large) that allow one to select “try fedora” or “install fedora”. Are you saying that first option does not even appear?

If it does appear and one selects “try fedora” it then finishes booting to a gnome desktop. One of the icons on the activities menu is now “install fedora”.

What exactly are you seeing or not seeing when booting the live USB?

The only thing I recall from earlier posts about not being able to start an install (did not prevent booting to the live system) seems to be when windows was installed on the system and the sata device is in RAID mode. In those cases the fedora installer was unable to even see the drive for installing.

The fix there seemed to be that the user had to

  1. disable fast boot (if enabled)
  2. boot to bios and change the sata device mode from RAID to AHCI
  3. Boot to windows repair disk and fix windows booting.
  4. Then, finally, do the fedora install.

Maybe this is your issue or maybe not, but I don’t really understand from what you have posted above.

I was thinking the same but your info below is a bit to general. For information we use to help you, without guessing, please read #start-here

Pressig Alt & F2 while getting stuck brings you to a login? If yes try login with liveuser and press enter. Now you could ad least do some checks as lspci etc in terminal.

If it is about nvidia you can try this:

Sorry i not understood i5-6600k and 1060gtx
We do definitely need more infos

An intel i5-6600k CPU and nvidia GTX 1060 GPU
Although the OP could certainly provide better and more detailed info. I can understand that abbreviated info is difficult to interpret.

Can you show some pictures or video like what happening there after you reboot and insect the drive. It will give us more info as you can’t open terminal as you have told above.

The install or try fedora doesn’t appear neither do the taskbar or app icons but the wallpaper does.

Okay I found the problem. Apparently my computer thinks there are two monitors even though I had one. It was treating my monitor as monitor 2 thus not showing any prompts or apps.

Thanks for your help

Can you explain how it was solved and how so other if have the same issue could find it useful

I had two cables plugged into my monitor because my HDMI sometimes wouldn’t work. I think Fedora picked that up as two monitors, I fixed it by removing one of the cables.

I do have another problem now, the grub didn’t install so it would always boot into fedora so I changed the boot order in the bios and deleted the partitions in disk management and deleted fedora in powershell. Now it boots into bios and won’t boot into Windows.


Why you done that :face_with_hand_over_mouth:
It is easy to see grub again
It was fedora design not to show grub for better experience you can easily switch between them with holding shift key. And even you can enable grub. Anyways
I recommend install fedora again because maybe be windows bootloader was removed by mistake.
If you can’t see windows in boot in bios boot order or boot menu like that

Yeah I am learning, sorry. I couldn’t find anything on it so I assumed I corrupted the install. I’ve totally killed windows.

I can see windows bootloader in the bios but every time i click on it it sends me in circles to the bios. I tried windows recovery iso, doesn’t work. I can try install fedora again to see if that works.