Can't boot to Windows in dual-boot / No Windows in Grub and Os-prober

I’m new to Fedora, used Lubuntu a bit before. I’ve installed Fedora with Win 10 in dual-boot but after installing Fedora there was no Windows boot manager in Grub and os-prober doesn’t show anything. My disk partitioned using GPT, ntfs-3g was already installed.
Upd: I’ve just checked grub configuration file and there’s nothing generated in os-prober config. EFI Windows partitions also exist on my disk

Hello @watislan , welcome to :fedora: !
You should be able to access your systems boot selection menu provided by the BIOS to boot from Windows, in the interim. You can use efibootmgr to configure your boot menu, I would suggest typing man efibootmgr in a terminal to get a thorough explanation.

I’ve just thought that Fedora might be installed in bios mode, while Windows was installed in UEFI mode. Reinstalled distro using manual disk partitioning and it worked for me. I think this discussion can be closed now.

Glad to hear you sorted that out. :saluting_face:

Just as an FYI.
For me, when I boot a USB install iso I find that the bios boot menu shows 2 different selections for booting the USB device. One is plain, the other shows UEFI on the image. Depending upon which is selected the mode used for boot and install is determined at that point.

At present it seems a disk with windows installed in uefi mode will always show as gpt partitioned and in legacy mode install it will always be msdos mode (MBR) partitioned.

To avoid having to select the boot mode at the bios boot menu you could possibly set the bios to boot UEFI only then the option to boot in legacy mode does not appear.

I assume that your reinstall was done in uefi mode though you did not state that.

You may mark the post showing the fix as the solution and that tells everyone that it is solved/closed.

1 Like