GRUB only shows UEFI firmware settings and Windows boot manager

When booting to GRUB, it only shows the options “UEFI firmware settings” and “Windows boot manager”. I’m trying to dual boot Fedora and Windows 11, which worked before on my PC. Any help?

Please provide more details. I assume you can’t get Fedora to boot, so troubleshooting may require a bootable USB device (e.g., the Live Linux Installation ISO).

When you say “worked before”, do you mean a previous installation or that the current installation has “lost” the Fedora entry? If the latter, make sure that windows 11 fast startup is disabled (this is a form of hibernation, so may interfere with linux startup). We may need to view your disk layout as seen by linux.

I mean one of my previous installations, also fast startup is disabled

Do you mean that this is a clean install and the earlier ones were cleanly and completely removed?
Or did you upgrade from a previously functioning install?

The difference may be important as to what might be on the fedora installation area. How the installation or upgrade was done may be a factor.

As is often quoted: “The devil is in the details”

So I have to assume you are having the problem with a fresh install made with the Live ISO. There are rescue capabilities in the Live ISO. See:
Working with the GRUB 2 Boot_Loader is a “work in progress”, so cross check with the other documents or ask when something isn’t clear.

I’ve removed all of my previous ones, so it’s a clean install