Windows 10 won't boot after installing Fedora 32

Problem: windows 10 won’t boot after installing Fedora on the unallocated disk space. Fedora boots just fine, grub shows up, but does not offer a windows boot option. Accessing BIOS boot menu yields only the following options:

There used to be a ‘Windows Boot Manager’ option. Two of them, in fact. I suppose there were two because this laptop came with W8 and was forced to update to W10 later.
Windows data, however is still intact. It is even accessible from the file manager. Also, see:

sda7-9 all appeared after fedora installation.
Trying to boot with gpt-style W10 setup usb yields black screen. Trying to boot with mbr-style W10 usb works, I can even run a command prompt, but I don’t know where to go from there.
Also, I must confess that during fedora installation I didn’t pay much attention and pretty much went along with all the default options. I didn’t know about UEFI, mbr, etc. Also, an interesting thing to note about UEFI, in my bios there’s an option to ‘choose OS’ and the choice is between W8 (which is not installed) and “Others”. If I choose W8, I get the option to ‘enable UEFI boot’. What.

Will removing the sda7-9 partitions solve the problem?
PS: I saw an advice on the internet to just type exit into grub command prompt which would allegedly let me boot into whatever OS i want. It didn’t.

PPS: apologies for the crappy photos.

Boot your Fedora and please post the output of

sudo efibootmgr 

That’s never good.
I assume during the install of Fedora you pointed the efi partition (mounted to /boot/efi) to the existing efi partion (created by Windows) and maybe the check box ‘format partition’ was set. In that case your Windows bootloader was kicked.

Not sure what the best way to reinstall a Windows bootloader is, but I guess a Windows Installer can repair the issue. Afterwards you may need to reinstall the Fedora bootloader.

As long as the screen works and folds correctly…

Boot your Fedora and please post the output of

sudo efibootmgr 

EFI variables are not supported on this system.

Sounds like you installed Fedora in legacy BIOS mode, also there is a sda7 (bios boot).

In your BIOS, what happends if you set ‘UEFI Boot’ to ‘Enabled’, does Win show up? Once a system is installed, you should never change the UEFI/BIOS mode and install another system. This hybrid stuff doesn’t work.

1 Like

nothing boots, stuck at bios. If I recall correctly setting it this way didn’t cause W10 to become unbootable.
Also a new option appears

“Launch EFI Shell from filesystem device”
It does nothing, even though EFI partition is still there.

Managed to boot uefi usb and repair efi partition. Still nothing. Windows startup repair tool claims that all is fine, but bios won’t offer me a boot option. I also deleted fedora’ partitions, so i guess i should take my problem to other forums. Nevertheless, it’s been educational. Thanks,florian.

Hello! I have the exact same problem as you do. Did you find a way to fix it?


Since this thread is old, please post a new thread with your problem.
Also please read the “Start Here” category first to get the most out of this forum.