Fedora not showing up in GRUB

I am currently trying to dualboot Windows 11 and Fedora 40. When I boot off of the live USB, I am able to install Fedora as normal. It finishes, then tells me to restart. If I take out the USB as it’s restarting, it boots into Windows. If I don’t, it boots into GRUB, but only shows the options to boot into the Fedora Live install, to test the media, and troubleshooting. It does not show the options to boot into Fedora or Windows, and is identical to how it was before installation. The Fedora partitions are there when I open Disk Management in Windows, so I don’t know what might be happening.

If it helps, I’m on a GF63 Thin 9SC (MSI) with the battery removed, and the USB stick I’m using is a Sandisk USB 3.0 256GB one.

If anyone could help, that would be great!

Try using the Bios boot menu to see if it can find the Fedora boot option, it usually will.

Thanks for the quick reply! There’s no fedora option in the BIOS.

Do you see a windows 11 boot option in you bios?
The fedora should be in the same place.

Are using UEFI or legacy boot?

You can query the UEFI bios using the live usb.
Run sudo efibootmgr to see the boot order details.

There is a Windows option in the BIOS, but no Fedora, and neither show up in GRUB. I’m using UEFI. When I ran sudo efibootmgr in the live boot, I got this:

The images has Fedora clearly shown, twice.
Look at the line that starts Boot0001* Fedora and `Boot0006* Fedora.

I would expect that you will be able to make that the default to boot in the BIOS.

I think this command will set it to boot grub if you cannot find the boot menu in your BIOS: sudo efibootmgr -o 1

I used

sudo efibootmgr -o 1,0

to set it to boot Fedora, then windows. The command itself worked, and the list changed to match. However, it didn’t actually change anything. Neither Windows nor Fedora show up in GRUB, and Fedora does not show up in the BIOS boot menu. The order also does not save (it gets reset after a reboot). Is there a separate command I need to use for that?

Then you must find the boot order section of your BIOS.

If you cannot find it from navigating then search for the motherboard or laptops manual and read how to do from that.

Is Windows fastboot disabled? There can be fastboot options in Windows and/or BIOS settings.

1 Like

I’ve already told you several times that Fedora isn’t one of the options in the BIOS. That’s where I’ve been looking and I’ve already told you it isn’t there.

It was not. I disabled it, but it didn’t seem to do anything.

Is it normal that both Windows and the 2 Fedora images have the same UUID in the sudo efibootmgr output?

In the lines of the form:

Boot000<N>* <OS>	HD(1,GPT,<UUID>,0x800,0x145000)/\EFI\...

the UUID’s all refer to the location of the EFI directory, so yes, it is normal.

1 Like

The reason I keep insisting you look in the BIOS is because, personally, I have never seen a BIOS without a boot order option. It might be hidden behind an advanced mode.

I think we’ve been misunderstanding each other. When I say Fedora doesn’t show up in the BIOS, I mean it doesn’t show up here (the boot order menu):

Whappens if you from “USB Hard Disk”. It should boot EFI/BOOT/BOOTX64.EFI, which should be an identical coppy of EFI/fedora/shimx64.efi.

The UUIDs you find in the efibootmgr listing are partition UUIDs which can be shown by the command


I have read – don’t remember where – that some old UEFI implementation can remove boot entries if the entry label or boot images isn’t on a list of valid entries.

@turbulence you could see if there is a newer bios available that may improve thing.

I updated my BIOS and then tried again, no luck.

You have shown use the “Fixed Boot Order Priorities”. When you want other than the “fixed” options you need to look for Fedora in the “UEFI BIOS Boot System( BBS)” to see the settings that efibootmgr shows. You may, however, find that your BBS censors the list you get from efibootmgr.

1 Like