Fedora not visible in grub

After install Fedora 38 dual boot with Windows. Fedora not visible in grub only show Windows. So I can’t boot into Fedora. How I can fix this?

Are you sure that you are booting Fedora’s grub and not another grub that you had from a past install?

yes I am sure

I would assume the kernel did not properly get installed and grub properly updated.
That screenshot appears to show the grub menu so booting to a live media and doing a recovery (or a new overwrite install) seems the best choice.

Since F38 was released this week the overwrite with the released media seems best choice to me.

Boot a Fedora 38 live session, set up chroot, restore GRUB, and perform full upgrade:
Restoring the bootloader using the Live disk :: Fedora Docs

This should install a newer kernel and also fix the bootloader.

I have been doing reinstalling and still same problem. i choose efi file shim.efi, grubx64.efi, and shimx65.efi still same. Previously this problem not happened in Fedora 36 and this happened in Fedora 37 and 38

I have been trying this and you know what happened. The grub show only UEFI firmware settings and the Windows boot gone.

What is the setting of GRUB_ENABLE_BLSCFG in /etc/default/grub?