Can't find Windows 11 bootable anymore after installing Fedora KDE


Today I have installed Fedora on an SSD along with Windows 11. The SSD was clean, I installed Windows 11 first, then shrank the volume of its partition and proceeded with the Fedora installation on automatic. I followed this super detailed video and guide.

I got to the last point, so my Fedora installation seems fully functional, but although I would rather not get Windows as my priority boot, I want to switch every now and then. So I went through the commands to modify the grub manager.

However, when I boot up the PC and enter the BIOS I don’t have any OS choices, just my SSD on which I have both the OS installed.

I don’t have a choice when I turn on the PC. I get sent directly to Fedora, which is fine mostly but , how can I make sure to do that? This is how my disk partitions look like, I have not touched them after the Fedora installation.

EDIT: I tried to look into what could be the issue, and noticed that when I try the command efibootmgr it says that efi variables are not supported on this system. So there must be something wrong with these in the origin I believe.

This means that Fedora has been installed in classic bios mode and not UEFI mode. Because of that, it is not possible to boot windows which has been installed in UEFI mode.

When booting the Live system, it is important to select the correct entry. In some cases you get a choice of UEFI mode and non-UEFI mode. If so, you should select UEFI mode. The exact details depends on the machine you are installing on. Also, the way you created the install media could have prevented you from booting in UEFI mode. The recommended way to create the install media is to use Fedora Media Writer.


Thanks @vekruse , your comment is exactly what I needed.

I have an ASUS motherboard so the BIOS had a different setting name, and its called CSM here. I had to format the drive, then I disabled this CSM, and I switched secure boot to “Other OS”. After this I just repeated the steps in the guide above and it all worked smoothly.

Compatibility Support Module (CSM) is the common term for classic MBR BIOS booting

1 Like