Installing Fedora 36 on a USB Stick

How can I install Fedora 36 Workstation on a USB stick? Permanent installation not a live mode is what I’m looking for. Should I use the method of two USB flash drives (one for the live mode that will help me to proceed full installation on the second one) or is there any other easier and quicker way?
Thanks in advance!!!

1 Like

I think the two USB devices is likely the way to go.


Another option would be to use qemu to install it by mounting the iso and usb-stick and doing the installation that way with only one USB stick.

For example, assuming your USB stick is at /dev/sdb (change it accordingly if it’s different!) :

sudo qemu-kvm -m4096 -boot d -cdrom /path/to/Fedora-36-image.iso -hda /dev/sdb

The -m 4096 is to give qemu 4GB of memory to work with, which is the current recommended minimum, so make sure you have 4GB to spare on your machine before running this. It’s possible to install it with less than this, but I wouldn’t go less than 2GB and expect a slower experience.


Thanks Jeff!

Thanks Scott! Very nice to know indeed but I will be using a windows machine for this procedure so …

I have written a few articles about that:

this one shows how to do that by using two USB sticks

but you have to pay attention not to overwrite the main EFI.

This one instead is safer, since it uses VirtualBox, and you don’t risk to overwrite the main EFI:

hope it helps

1 Like

Thanks Lorentzo!!!
Much appreciated!

I did installed succesfully Fedora 34 and Ubuntu 20.01 in two different USB and i’m checking both OSs.
I tried to install Fedora 35 and Fedora 36 Beta but (i don’t know why) i couldn’t boot with neither of them!

BIOS recognised the stick but when it was selected as the boot device it proceeded for a little bit and then stucked.
I was really surprised because the computer i was working at is not an old machine but unfortunately i didn’t manage to see both last mentioned Fedora editions.
I intend to wait till Fedora 36 final release to try again.

Anyway …
Thanks again for your mail!


Στις Παρ 15 Απρ 2022 στις 10:50 π.μ., ο/η Lorenzo Bettini via Ask Fedora <> έγραψε:

If it’s an old machine, it could be the case that you installed Fedora with UEFI, but your machine is set to BIOS boot instead of UEFI (or if it’s old enough, it might not support UEFI at all). If it does support UEFI, make sure you’re running the latest vendor firmware on it, so you can support the newest signing keys for secureboot (or temporarily disable secureboot in the meantime).

1 Like

Hi Scott!
Thank you for your support.

The machine i’m using is a HP desktop (model 2019) with AMD Ryzen 5 and 8 GB RAM. It’s not brand new but you can’t call it old, i think … especially for Linux. It runs Windows 10 perfectly.

Anyway …
I’ ve installed Fedora 34 on a USB drive and it worked flawlessly. When i tried to uograde to Fedora 35, the procedure was completed with no indication of a problem but on rebooting after the upgrade it just couldn’t reboot! After some common basic signals that i always get during rebooting, i saw a black screen. Stacked and waiting. After 3 hours, exactly the same!
Same situation when trying to reboot after installing Fedora 46 beta on the same USB drive!

I’m not an expert, i know some basic things but i couldn’t do anything about it.
I’ ve updated the BIOS and especially the UEFI but problem remains.

I just don’t want to install Linux on the computer itself without giving it a try on USB drive first. I like Fedora and i want to use it but maybe i’ ll turn to another distro. Ir maybe the problem is with Gnome 42. I just don’ knowI forgot to mention that i have same booting problems when trying to use Fedora 35 or 36 beta via a DVD Rom.

Thank you again for your effort!

Στις Παρ, 15 Απρ 2022, 22:34 ο χρήστης Scott Williams via Ask Fedora <> έγραψε:

1 Like

Have you tried using the fedora 35 live iso on a usb stick to boot? I am not sure, but there are hardware differences between DVD and USB so there may be software differences as well in booting.

Yes i did Jeff!
No matter what i checked, as far as i know cause i’m not an expert, i still can’t boot from either a USB stick or a DVD Rom. Not with Fedora 36 beta or Fedora 35. Fedora 34 is the only Fedora distro that i can use for the moment.
I will wait till the Fedora 36 final release is out and i’ll try again.


Στις Σάβ, 16 Απρ 2022, 19:53 ο χρήστης Jeff V via Ask Fedora <> έγραψε:

Hi @konstantinosx

I might suggest some hints if you can confirm that your BIOS is in UEFI mode.

It is possible your issue is somewhere between the BIOS/UEFI stage and grub2 (on some HP it may be tricky, I’ve been tweaking with Fedora 28-36 LiveUSB a little bit and ran on odd issues):

  1. Could you elaborate on your previous answer in bold:

Some screenshots of the BIOS settings might be usefull

  1. Could you please how you created your Fedora 34 and 35 Live on USB ?
    I would recommend you the official method:
    Creating and using live USB and more precisely Using Fedora Media Writer since your system is Windows 10.

  2. Can you boot with your Fedora 34 or even better 35 Live on USB and show the result of:
    sudo efibootmgr -v

Hi Mahdi!

Thanks for your concern!

About my boot problem:

I think that yes, BIOS is in UEFI mode. Is it possible to boot with Fedora 34 and use it properly if the BIOS is not in UEFI mode?

According your hints

  1. On HP Desktops like mine you get into boot devices BIOS menu by clicking F9 and then you can select the boot device of your choice.
  2. Yes, i’ve used Fedora Media Player (for all 3 Fedora distros numbered 34, 35, 36 beta) but also tried with Rufus and balenaEtcher.
  3. I will try to show you the result of the command you suggested to me ASAP because i’ve erased Fedora 34 from my usb stick. With Fedora 35 Live or installed (or Fedora 36 beta) i can’t boot properly. Actually this is our problem.

I’ve got informed about this: Maybe this is my problem!!!

Thanks again!

Στις Κυρ 17 Απρ 2022 στις 9:53 μ.μ., ο/η Mahdi via Ask Fedora <> έγραψε:

1 Like

You said the bios is set to uefi mode. Since the live iso is a hybrid iso and able to boot either legacy or uefi mode, I have to ask if you are selecting the usb device that is indicated as uefi or the one not indicated as uefi when selecting the device to boot from in the bios boot menu?

If the machine is set to ‘uefi only’ in bios and you do not select the ‘uefi’ usb device to boot from, the boot will fail.

As far as whether you can boot fedora 34 in legacy mode, yes.
All the recent releases are done with hybrid ISO images and can be booted and installed in either uefi or legacy mode. The install is done in the same mode used to boot the install ISO.

When you say you can’t boot properly, please provide details as to what you see, how it fails, how far it progresses before failure, etc. With this info we may be able to tell what is actually failing to start properly.

1 Like

Some screenshots of the BIOS settings and boot options would be indeed usefull to help you as @ computersavvy and I did suggest.