Black screen after booting to live USB (before installation)

I downloaded the Fedora 36 Workstation x86_64 ISO file from and wrote it to a USB drive in the usual manner. I booted to the USB in UEFI mode. Trying to boot it in legacy mode results in “insert proper boot device and press a key”. I was then prompted with a GRUB menu to either test and boot Fedora Live USB, or just boot Fedora Live USB. Neither work; both of them result in my keyboard and mouse lights turning off for a bit and then back on, but then just a blank black screen from there.

I tried the following fixes:

  • Adding nomodeset to the second line of the GRUB configuration accessed by pressing E on an option on the GRUB screen. Both of them say they are booting from the list and freeze at that point.
  • Unplugging one of my dual monitors
  • Unplugging the other monitor
  • Using a different USB port

Edit: Using a different USB drive also doesn’t work.

My hardware:

  • AMD Ryzen 5 5600X
  • NVIDIA GTX 1070 Ti
  • Four hard drives: 256 GB NVME SSD (contains a copy of Windows 10), 500 GB SATA SSD (contains a copy of Ubuntu 22.04), 500 GB SSHD (contains misc. data for Windows 10), 1 TB SSHD (contains misc. files for Ubuntu 22.04

My goal is to install Fedora over Ubuntu on the 500 GB SATA SSD. Note that this error occurs before installation. I was unable to get to the point where I could even install Fedora.

I am not sure I understand.

You said that you were able to boot in uefi mode but not in legacy mode. That implies that the bios may be set to boot uefi only.

Why would you wish to boot legacy mode only, since it appears the machine is set to uefi and uefi is the way machines are built today?

Did it boot fully into the live mode with uefi or is your statement incorrect? Is the black screen from continuing to boot in uefi mode or is it from continuing to try booting legacy?
Is windows installed in uefi or legacy?
Was ubuntu installed uefi or legacy?

The issues all arise from attempting to boot UEFI. UEFI “works” in the sense that it gets to the GRUB screen (but not past that); legacy mode straight up does not recognise the boot medium, hence “insert proper boot device and press a key”. As for why I would do that, it was simply one of the things I tried after initially attempting to use UEFI and encountering the stated error.

Both Ubuntu and Windows were installed using UEFI. Legacy mode is really an unimportant part of the question. I just mentioned it so “try again in legacy” isn’t offered as a potential solution.

No combination of the above-mentioned settings results in a successful boot to live mode. GRUB is as far as it gets as far as I know.

I managed to solve the problem by writing the ISO file to the USB using GNOME Disks. So it looks like the problem was with how the USB was made.

And how was it made? Just so people can know how not to do it.

I made it by manually formatting the USB to FAT32 and copying the files from the ISO to the USB drive using a graphical file manager. I did this because it works for Windows ISOs and it worked once for an Ubuntu ISO, so I reasoned it would work for a Fedora ISO as well, which ended up being not true, hence the problem.

So this problem is entirely user error, tl;dr.

Fedora ISOs are hybrid, meaning they can be booted either as legacy or with UEFI. They are an iso9660 image and writing the iso to a usb device with dd, or etcher, or most other methods that copy the image (even using cp in linux can be used) to the usb device, will work. When all you do is copy the files instead of the image it breaks booting as a hybrid image. Preformatting the USB device is not needed, and can interfere with properly writing the image to the bare device.