Boot issue: Fresh fedora install will not boot at all

Hi all!

I am attempting to establish a dual boot with fedora workstation 30 on my ThinkPad P52. I currently have a drive with Windows 10, and a separate disk that I installed Fedora 30 onto with a USB stick that I created using Fedora Media Writer. I go through normal installation steps, and the fedora installation program claims to be successful, but upon reboot the boot loader presents a Boot Order error, attempts to make a ‘0001’ entry in the boot list for Fedora, and then resets the system ad infinitum until I open the BIOS Boot Menu and force a boot into Windows. Attempting to force a boot into the drive with Fedora installed results in the same error.

I do not think it is an issue with my BIOS configuration or UEFI boot order, because I previously had openSUSE installed on this same drive and GRUB would work just fine with that OS and Windows on separate drives.

TL;DR – Dual Boot Fedora and Windows (OSes located on separate drives) on ThinkPad, Fedora installation won’t boot at all.

Hi, @edgaralleno and welcome to Ask Fedora!

For the benefit of others I’ll add a link to thread with similar problem (on different hardware), I assume @edgaralleno read it and tried workarounds suggested/discussed there:

As I’ve posted in that thread, the problem seems quite widesperead – and not only with Fedora, there are easy to find reports/questions with other distributions too. It seems to be some sort of incompatibily with UEFI on some (older?) notebooks and newer (?) versions of grub efi loader. There are some very informative links in that thread (in particular stating people were able to resolve this issue on Fedora by downgrading grub to version from F26 if memory serves) – with some workarounds discussed – but no one fits all solution.