Failed to write boot loader configuration, Fedora 30 UEFI dual-boot with Win10

I am hoping someone can help me. I can’t install Fedora 30. My set up is basic, a single hard drive laptop, dual-booted with Windows 10 (yes UEFI). I have previously installed Fedora 25 and 27 on this very same machine in this very same configuration successfully. But no matter what configuration I try I always get the error;

“The following error occurred while installing the boot loader. The system will not be bootable. Would you like to ignore this and continue with installation?”

The only errors in /tmp/anaconda.log are;

13:45:37,700 ERR Bootloader configuration has failed: Failed to find a suitable stage1 device: EFI System Partition must be mounted on one of /boot/efi.; EFI System Partition cannot be of type None.; EFI System Partition cannot be of type ntfs.; EFI System Partition must be mounted on one of /boot/efi.; EFI System Partition cannot be of type ntfs.; EFI System Partition must be mounted on one of /boot/efi.


18:58:45,752 ERR bootloader.grub2: failed to set menu_auto_hide=1
18:59:08,997 ERR bootloader.installation: bootloader.write failed: failed to write boot loader configuration

If I create the partitions completely manually the first error seems to not happen, but the second one still does. I don’t know what else to try other than an older Fedora image, any help greatly appreciated.

I just installed Fedora 29 first try. Something is broken in 30.

Hello @chebegeek and welcome to the community! Please take a minute to go through the posts in #start-here if you haven’t already.

There is another post that seems similar to your issue, but upgrading from F29 and not while performing a fresh installation. However you could find some useful information.

Hi @alciregi, thank you for the welcome! That posts describes a different problem, and luckily one I did not encounter when I upgraded my fresh 29 install to 30. I’m beginning to suspect I just have better luck with the odd numbered versions :slight_smile:

Well and I’m just going by the error messages in your first post…

…is your EFI partition formatted as FAT (FAT32 I think actually to be more specific)?

An EFI boot partition has a special type GUID (in the new format, GPT, partition table) it’s not identified by its file system type.

It is conceivable that Windows created this partition as NTFS and has no trouble with it - but Fedora can’t use it.

One possible workaround would be to try manual partitioning and create a new EFI boot partition just for Fedora.

1 Like

Hi @kmansoft, thank you for your reply.

I tried manually creating the partitions, it didn’t help. The only thing that helped was installing Fedora 29, which worked, so the boot partition must be just fine.

I have been having the same problem with Fedora 30. I will try 29 and see if it works.

I have the same problem with Fedora 32. I can’t believe that this problem exists since Fedora 30 and has not been fixed. There is a solution to this problem, but it’s not a nice one. You have to create two extra partitions:

  • /boot
  • /boot/efi (type: EFI System)

Then you can install Fedora 32. I don’t know if this affects secure boot in any way.

No it does not

Com’on, what is wrong with having a /boot/efi partition? Besides, you are not actually creating a physical partition there … you are only mounting an existing physical partition into the Linux filesystem under /boot which is the real physical partition. Whether you choose to install Fedora or not, UEFI booting requires a dedicated partition called an “EFI System Partition” (bootable FAT32). EFI partitions are created once. If you have Windows-8/10 on that box, chances are that you already have an EFI partition. You will be mounting that partition as /boot/efi (there is a difference between mounting an existing partition and creating an entirely new partition)

I have had no problems with installing dual boot with windows on any version in the last 6 years. The only caveat is that I used the original windows efi partition and mounted it at /boot/efi with a plain ext4 partition at /boot. Everything else has been LVM and never an issue.

Others have said they created a separate efi partition so effectively they had 2 efi partitions but they also had to do a little playing with grub to boot both OSes.

The issue AFAIK is that grub cannot access LVM before the kernel loads, and UEFI cannot access anything not formatted as efi. As @twohot said, one existing efi partition and you select the mount point as /boot/efi and one new partition at /boot. That is NOT a dirty or difficult situation and has been the normal for years.

1 Like

That is a clear message.

Did you install on a GPT partitioned disk? using UEFI? or are you trying to do a UEFI install on an older MBR partitioned disk. A UEFI install on an MBR partitioned disk will not work.

Once the UEFI install is complete the grub.cfg file will be located in /boot/efi/EFI/fedora.
For an MBR boot system the grub.cfg file will be in /boot/grub2.
Your error messages suggest you are installing UEFI without an efi partition mounted at /boot/efi

I didn’t think of mounting the first partition, am not that experienced with linux.

I have two efi partitions now. Next time I’ll mount the first partition as /boot/efi. I didn’t have any problems with grub though.

I had the same issue and what worked for me so far was Fedora 33 Testing version (idk if it was by luck or bug fix and I hope that without future problems).
Download for Fedora 29 ISO file was estimated for 3h to finish for which I did not have time.