FC34 started to turn off my display after recent updates


I want all power saving features completely disabled, forever. Somebody helped with this before but despite me not changing anything and having it work as desired for a long time, it broke again recently.

Would somebody please tell me how I can restore the desired behavior? I don’t want the display to turn off, ever. And I don’t want any power saving at all on this box.

I’m using i3wm as my window manger, I don’t use gnome or kde.



You can double check changes here

you could also just open up a terminal and do journalctl -f and hopefully see what’s causing the issue.

1 Like

Hi, since you’re using i3wm you could install sudo dnf install xset. Then turn find the options you need with xset --help.

For example to turn off energy saving with xset -dmps or force the display always on xset dpms force on and many more including enabling or disabling the screensaver.

1 Like

Thanks but I suspect this has nothing to do with i3. It is more likely to be another breaking change in Fedora/updates.

Thanks, I don’t want to set this per user. All power management on this box should be off, globally.

sudo dnf rq --installed --recent --qf "%{installtime}\t %{name}-%{version}"

Recent defaults to 7 days, if you need it to go further prior to recent add
–setopt=recent=“how many days you want to go out”

1 Like

Thank you @grumpey

I have a terminal window running journalctl -f
I will see if I can track it down. If not I’ll try to go over the updates but I guess that will much harder.

Power management has been changed to powerprofiles and as such, on my system it defaulted to balanced after upgrade and only made available options for power saver mode or balanced mode, and I run a desktop PC no less! Admittedly with a newish MB, but anyway it (the upgrade from F33) did the change on me without notice at the user level. Still not entirely satisfied with the power management on my system, and would be really “steamed” (no pun intended) if I couldn’t overclock to play high motion games for instance.

1 Like

This is a server box and I usually have a bunch of terminal windows open to watch what’s going on on my headless servers. To have the screen go blank is abominable.

I have no idea how to look at power settings since I don’t use KDE or gnome.

I just removed sysstat, upower, and the gnome-desktop group and reinstalled xWayaland. Let’s see what happens. Unable to find any other hits for dnf list --installed | grep power

update: no breakage after rebooting, but will have to see if the screen turns off when I am not using it

Screen still turning off… the outrage continues

Are you using the default configuration?

Is i3 lock or xss-lock running? What happens if you kill them.

1 Like

Maybe you could change on systemd part here: How to Disable Suspend and Hibernation Modes In Linux

Or, you could check the following file setting: /etc/systemd/sleep.conf.


I don’t know what you meant about a default configuration. i3 lock and xss-lock are not running.

Thank you @oprizal I updated the sleep.conf and also found helpful info on the page you linked. I’ll update the thread if it helped.

1 Like

The default configuration for i3.

I have certainly changed it, but not recently. Last change seems to have been in July.

The screen turning off is something that has happened within the last week, probably around Wednesday or later.

The sleep.conf, I believe will still turn off your monitor, but it’s prevent to sleep.

Thank you @oprizal and @grumpey for your advice and help on this.

After I followed the example on the page that @oprizal linked about disabling suspend and hibernation mode, the problem persisted. I rebooted and it seems the problem did happen once.

But after that, it seems to be ok, the screen is not turning off. I am not 100% sure this is fixed but it is definitely much better.

I did find I had a few xset commands in my .xinitrc but at some point (probably when I removed tons and tons and tons of gnome stuff trying to diagnose/fix this issue over the past 2 days, xset was removed). I reinstalled it. So, with all these changes I can not conclude which one(s) helped.

1 Like

But please do mark what you think was the primary contributing solution.

I did that at the time of my post- please see what @oprizal wrote and the link he gave to the 3rd party page which shows how to turn off hibernation etc permanently :slight_smile: