Screen never recovers after it goes to sleep


I need some help! After a recent dnf upgrade my F33 system suddenly fails to wake the screen after putting it to sleep. I’ve tried to debug this further but can’t determine where the problem is coming from. I created bug 1900890 but am not sure if that ticket is even logged against the right component.

I would really appreciate help with any workaround that allows me to keep the computer running but still manually recover or avoid this situation entirely. Currently I have to hard reboot the machine to regain access to the GUI as that seems to be the only way to wake the screen back up again. I haven’t found any magic key combination that allows me to wake up the monitor. I was able to disable the monitor going to sleep entirely so now I can manually power it on and off myself.

This seems similar to the topic except that I’m using Intel video drivers instead of NVidia and I’m using Gnome instead of XFCE.

I could really use help on this. Having to restart the computer every time I step away is painful and disruptive. Thanks in advance!


I also have a problem with waking from sleep, but it’s different. The screen turns on, and shows the lock screen, but i can’t get beyond that - there’s no password box, and nothing happens if i click, press keys, etc. I also can’t switch to a different virtual terminal. The clock on the lock screen is wrong - it shows the time the machine went to sleep.

Hibernation works, though.

When I leave my workstation for longer than 20 minutes is when the trouble starts. When I turn my monitor back on fedora 33 will not send any start up packets to the monitor. I have to restart my computer before the CPU sees the monitor.

Anybody ever seen anything like this? It’s a first for me. I thought it was my monitor, but this is the same system I was running fedora 32 on with no problems.

I could not find any post on this subject, so I created a new topic, which is pretty much the same issue of going to sleep and not waking up. You have to restart the CPU. It is just the wife and three grandkids, and they have no interest in what I’m doing on my PC. So I might as well turn Automatic Suspend “Off” and set Blank Screen to “Never”.

That will fix my issue, but it does not fix the problem with Fedora 33. I did not have this bug with Fedora 32.

Are you turning the monitor off? or allowing it to go into power save? If turning it off the issue may be that fedora no longer remembers the configuration for it since it has no connection. Then the display manager cannot reconnect when powered back on.

I have never, on any version of fedora (including 33) while running gnome, had a problem with the monitor not waking up. I have always allowed it to go into power save when the PC goes to sleep and have never turned the monitor off. With the monitor on but in power save the connection is never interrupted.

I am experiencing the same problem, after upgrading to F33. I have a desktop PC vs a laptop. Thus, my PC should never go to sleep.

I found that my screen size was being set to 1024 x 800. So, I reinstalled the NVidia drivers from NVidia. Now, when the lock screen is turned on, either by time out or by me, all applications are closed … UNLESS - I leave CHEESE running.

If CHEESE is not running, the desktop quits and when I try to unlock the computer, the monitor says … NO SIGNAL …

I can get back to my desktop, by pressing CTRL+ALT+F2, and then pressing CTRL+ALT+F1.

This seems to kickstart the display service and I get the login prompt. But, any application that was running when the Lock Screen was initiated is closed.

I checked my power management settings … The computer is never to go to sleep. The display can go to sleep after 10 mins. These settings though should not affect the display service, by causing it to bomb, close, shut down or otherwise quit.

I have similar problems using intel graphics. When I lock my screen the monitor goes blank and then the machine crashes entirely. Even ssh connections will drop. Worked on with older kernel, 5.7 if I remember correctly. Reported upstream (, but does not seem to be a high priority issue. Setting ‘i915.modeset=0’ as kernel parameters in grub solves the machine crashing issue, but the screen won’t light up anymore after wakeup. Can unlock blindly though.

Maybe it can help you?

This is exactly what I started to experience this past week on F33, just as you describe. After waking, my screen turns on and I see the lock screen, but it never goes any farther than that. Did you ever resolve this?

I can ssh into the machine, so perhaps there is something that just needs to be kicked.

@heavy if you can see the lock screen then you might have a different issue. In my case, and as further discussed in bug 1900890, after resuming from suspend the screen remains dark.

I found a temporally solution, that solve a problem: adding ‘no_console_suspend’ kernel boot option (grub.cfg), after that don’t forget update grub. I hope it can help so you feel free to try it.

Yeah, it is different from you, but it was the same as what @twic was describing.

I actually can ssh in and kill the lock screen using the shell, which then shows me my desktop with all of my apps running, but none of my input devices are responsive, so I can’t do anything.

This just started last week for me after being on F33 for quite a while. There was an kernel update after I rebooted this morning, so I’m crossing my fingers there is a fix in there.

1 Like

@grsm Thanks for the suggestion, I’ll try that if this mornings kernel update doesn’t resolve the issue.

1 Like

@heavy good luck, hopefully the update resolves your issue!

Oh sorry, you have a different problem. You can see the screen after resume, but I was think that is stayed black.

@bfallik Do you know if this problem was patched eventually, and if so what the patch was called? I have this problem now in March 2020 and it just happened after a recent system update (I’m on Fedora 35 KDE DE). I have tried rolling back and still nothing. I also tried the solutions from your original bug post with disabling the sound in the BIOS, still no joy :frowning:

Your post here is on a thread that is more than a year old and at least 2 past releases of fedora. Many things have changed in that time period.

Please start a new thread with a full description of what your present issue is so we can properly evaluate the problem and suggest valid fixes that are pointed to your current situation.