Adjusting screen brightness

So I recently installed Fedora 32 on a dual-boot and it’s been amazing, slowly making the system my own. The only issue I’ve run into lately, especially when it’s dark out is that I’m unable to adjust my screen brightness in any way. I’ve gone through the settings and tried making adjustments there but they don’t have any affect on the actual hardware. Any suggestions? I’m on a Dell G7 7500 laptop.

Thank you!

Hi @imntesta
The regular Fn+F10 or Fn+F9 key combination should work. I assume you are using Gnome DE, otherwise you may need to install light for tiling window managers like Sway/i3

2 Likes

Hello,

I’m using KDE Plasma for my desktop environment. Unfortunately the f9/f10 or fn+f9/f10 keys do not work, neither does toggling the brightness manually in my system settings. However on my windows partition it is working smoothly. How does sway work? I did some brief searching and it seems like I’ll have to reconfigure my desktop?

Thank you!

Hi
Brightness is controlled from “Energy Saving” in “System Settings”…
Another option called “Night Color” can automatically adjust screen color to smoother as light begins…
Search for these options in search box, in system settings…

HTH
Theodore

Have you exhausted your options in KDE?

Sway is not like Gnome or KDE. It requires a different mindset to graphical computing to enjoy it. Don’t expect fancy desktop animations. It is perfect for people who want their Desktop environments out of the way so the can focus on work. Sway depends on wayland and not X-server. You can install Sway and switch to it at the login screen (GDM, greeter) without messing up your KDE environment (I have not verified this for KDE, but it works for Gnome).

Alternatively, you can boot to level-3, login and execute sway from there.

1 Like

I had the same problem on my Thinkpad T430, this model happens to be the one with a discrete card, so it uses nvidia optimus technology. After turning the nvidia card off in the BIOS menu, brightness control seems to be fully functional. I’m still to figure out whether the problem is caused by nvidia optimus or if it is related to the nouveau drivers used on Fedora. Anyway, thought this could bring some insight to your issues.

1 Like

Probably related to nouveau. I have the nvidia drivers from rpmfusion on my laptop and brightness control works.

1 Like

In my i3 config, I use

bindsym XF86MonBrightnessUp exec blup
bindsym XF86MonBrightnessDown exec bldown

& I have blup & bldown scripts in a bin dir, which is added to PATH in my ~/.bashrc file:

export PATH="/home/reed/system/bin:$PATH" ## put it wherever you like

& blup/bldown NOW just call light -A 5 and light -U 5.

Some links I’ve found useful in debugging my video issues on Lenovo Gaming i3 laptop. I have nvidia graphics card, but have disabled the drivers because it created other problems I didn’t care to diagnose since I’m not gaming on here.

I thought I had other notes to add, but I can’t find them. fedora has a great page on setting up RPM fusion to get the nvidia drivers installed properly, but I can only post 2 links here as I’m a new user. It’s at docs . fedoraproject . org /en-US/quick-docs/setup_rpmfusion/

My Hero <3

I was using a much more complex setup with xrandr that washed-out my colors when I turned the brightness up.

Use the Extension “Soft Brightness Plus”, it just works! I have previously tried “brightnessctl” and “xrandr”, both didn’t work on my Acer system.

1 Like

Was really stuggling with this and this solution worked. Thank You.