Cannot adjust screen brightness on Fedora 30 - Gnome running under X server

After updating to Fedora 30 the screen brightness functionality stopped working. It worked fine on Fedora 29 and 28. I am running on a Lenovo 2-in-1 14 (81cw).

Thanks for any advice.


After I installed NVidia driver the Fn for brightness doesn’t work and I use the following from terminal:
xrandr --output LVDS-0 --brightness 0.6

1 Like

Thanks that works. But is there a way to undo or set GNOME back to be able to just use the ‘Screen brightness’ controls as they should?

Same issue here. It is also not possible to change it via gnome.

As far as I can remember, there was an option in some configuration file.
I manage to solve the issue some years ago on Ubuntu installed on a MacBookPro.
There was a file like xorg.conf, and an option like EnableBrightnessControl, but I don’t know if such file still exists and if this is your case.
Try to look on some search engine for the complete configuration.

1 Like

I found out that using Wayland it also doesn’t work.

But I’ll see if I can find something with your hints.

1 Like

Setting the brightness manually using echo 852 > /sys/class/backlight/intel_backlight/brightness works (maximum brightness can be found with cat /sys/class/backlight/intel_backlight/max_brightness)

But unfortunately I have no Idea how to fix it with gnome and how to fix the shortcut.

Then I tested it on a MacBookPro 5,5 so it could not be your case.
I installed the Nvidia modules suitable for this machine, from RPMFusion
sudo dnf install xorg-x11-drv-nvidia-340xx akmod-nvidia-340xx
Reboot: no backlight.

Then I added this line

Option "RegistryDwords" "EnableBrightnessControl=1"

inside the "Device" section of this file: /etc/X11/nvidia-xorg.conf
However it seems that this file is not taken into account.
So I made a symlink:

sudo ln -s /etc/X11/nvidia-xorg.conf /etc/X11/xorg.conf.d/98-nvidia-xorg.conf

And now I can adjust the screen brightness using the function keys as well as the slider bar of GNOME.

1 Like

… I don’t even have Nvidia drivers, nor to I have and Nvidia Graphics card. It’s a Thinkpad T460 with Intel graphics.

Had the hope that the issue disappears with some update but so far it didn’t.

Sorry @shoeper , I was answering to @ukulanne
BTW I have an Intel card (Intel Corporation HD Graphics 620) and brightness control works here out of the box.

It used to work out of the box for me as well. In think I started with fedora 24 and upgraded each version since. With fedora 30 it stopped working.

Faced same issue with Fedora 30 on Lenovo T460S.

# xrandr - this command will give you correct name to use

Use the name in above command’s output ex: eDP-1 for me.
# xrandr --output eDP-1 --brightness 0.5

Example Output of xrandr command on T460S:

╭─root at localmachine in ~ 
╰─○ xrandr                                
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080     60.03 +  60.01*   59.97    59.96    59.93    48.03  
   1680x1050     59.95    59.88  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

In the above output eDP-1 was the connected primary display.

1 Like

Just install xorg-x11-drv-nvidia.x86_64 package
$ sudo dnf install -y xorg-x11-drv-nvidia.x86_64
It helped me with MSI GL75 9SC. I hope it will help you as well :slight_smile:

I just wanted to thank you, you solved my problem! I’ve been looking around for a solution but there are so many to choose from… thank you again!