Brightness controls of my Lenovo laptop have no effect

Hello everyone,

I am using Fedora for the first time. Everything works perfectly so far, except a small issue with the brightness controls. Brightness is always at maximum in my laptop and I can’t change it. Brightness control keys respond and I can see the brightness bar goes up or down, but this has no effect. It always works at maximum.

I followed the solution in this thread but it did not work for me.

This laptop is a Lenovo Legion 5 (82B1000AUS) with AMD Ryzen™ 7 4800H Processor (2.90 GHz, up to 4.20 GHz Max Boost, 8 Cores, 16 Threads, 8 MB Cache) and NVidia Geforce GTX 1660 Ti.

Fedora 35 with Gnome
Linux version: 5.17.4-200.fc35.x86_64

I am not sure if they are related, but following error lines are from my dmesg output:

[   37.473611] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
[   37.473621] ucsi_ccg 20-0008: i2c_transfer failed -110
[   37.473626] ucsi_ccg 20-0008: ucsi_ccg_init failed - -110
[   37.473631] ucsi_ccg: probe of 20-0008 failed with error -110
[    1.867037] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/LNXVIDEO:00/input/input4
[    1.867166] ACPI: video: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    1.867231] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.GP17.VGA.LCD._BCM.AFN7], AE_NOT_FOUND (20211217/psargs-330)
[    1.867239] ACPI Error: Aborting method \_SB.PCI0.GP17.VGA.LCD._BCM due to previous error (AE_NOT_FOUND) (20211217/psparse-529)
[    1.867248] ACPI: \_SB_.PCI0.GP17.VGA_.LCD_: _BCM evaluation failed

This brightness level hurts my eyes, I can’t comfortably use my computer for more than a few minutes.

Any help will be appreciated.


Here are some additional information I collected by following this thread:

Output of ls /sys/class/backlight/:

Output of usr/sbin/lspci -k | grep -A 3 VGA:

01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)
	Subsystem: Lenovo Device 3a46
	Kernel driver in use: nouveau
	Kernel modules: nouveau
1 Like

I see you are using the Nouveau driver. Maybe using the proprietary driver that Nvidia provides would be worth a go to see if that helps?


have you tried out using different kernels? I posted a similar question (which you referenced), and found that on some kernels the brightness control works and others it does not.

More specifically: on 5.14.10-300.fc35 (and previous), the brightness control works, then for newer kernels, it does not work until 5.17.7-200.fc35, where it’s working again. Also, on Fedora 36 with kernel 5.17.7-300.fc36 brightness control keys work, as well.

This does not fix the problem, but at least solves it.

1 Like

Hey @blatzematze, thank you for your reply. As you said, brightness keys are functional when using kernel 5.17.7-300.fc36.x86_64.

I guess I’ll keep using this version and will try every new kernel version and check if keys are working with that version. If so, I’ll upgrade, otherwise I’ll stick with this version despite of the side effect of not receiving latest updates.

I wish this problem is solved for good. It seems it is a common problem with Lenovo computers.

1 Like